Community Forum

XFinitywifi Hotspot connects but says no internet in 48060

halloweve941
New Poster

XFinitywifi Hotspot connects but says no internet in 48060

I think this is in the right spot but if not, I apologize.

 

I've been using the month-long pass for the xfinitywifi for a few months now, renewing as needed, and there are issues sometimes but nothing that lasted this long. I run a business from home so having no wifi with speeds higher than 600kbps is taking a toll on my business. I can log into the xfinitywifi without a problem but it says no internet connection. I've read a few other posts with people having the same problem but I was unable to comment on them as they've all been locked.

 

If anyone from Comcast support reads this, I would appreciate some help. If I can't get this resolved I will need a refund on the pass as I'm not going to pay for something I can't use. Thank you in advance.

dnkdltn96
New Poster

Re: XFinitywifi Hotspot connects but says no internet in 48060

Hope someone responds to this soon. I'm having the very same trouble.
dorgg
New Poster

Re: XFinitywifi Hotspot connects but says no internet in 48060

I'm also having this problem on my Iphone 8, I was having this issue before the update to ios 14 so I know it's not due to that.

I also deleted and re downloaded the hotspot app which didn't work, also resetted my network settings. 

I've seen other forums mention going to general>profile>remove xfinity profile but that 'profile' option doesn't show up on my settings, so I am also at a loss at how to fix this.

It's also an issues across two devices the iphone and hp laptop so it might just be a problem on xfinities end.

Braden5656
New Poster

Re: XFinitywifi Hotspot connects but says no internet in 48060

I would also really like an explanation for this i have xfinity and im trying to use the hotspot and it says no internet connection its worked fine for months these past 3 days have been horrible because I can't connect to the internet for more than 5 minutes at a time
bohuang8888
New Poster

Re: XFinitywifi Hotspot connects but says no internet in 48060

Exact same problem with me too. Please let me know if you have found solutions.