Community Forum

XB6 Gateway and MoCA - Any Difference between Arris and Technicolor

Highlighted
Frequent Visitor

XB6 Gateway and MoCA - Any Difference between Arris and Technicolor

I am on the X1 platform for TV, internet and phone and until recently had an XB3 (TG1682G) gateway.  I have an ARRIS XG1v4 DVR box, an XG2 box and 3 Xi5s. 

 

I set up a MoCA network using 3 Actiontec ECB6200 MoCA adapters and 2 WCB6200 MoCA adapters (one on each floor).  The adapters are running on whatever the default MoCA frequency is.  Have had very stable TV and internet (at 350 Mps through MCA adapters and close at WiFI) for 2 years through this system, and everybody happy.  All signal levels are in spec.

 

Just moved to 600 Mps speed tier and Xfinity said I need to change to new XB6 Docsis 3.1 gateway.  They swapped out old XB3 (TG1682G) gateway for a CGM4140COM.  No other hardware changed.   MoCA is enabled, on Channel D1 (1150 MHz), as it was on the old gateway.  Getting 750 Mps speed, but we are now having intermittent connectivity issues with wifi and wired, and everybody is complaining.  I suspect this new gateway isn't playing well with the MoCA devices.   

 

Since my MoCA network worked well with the TG1682G (which is Arris), could swapping out  my Technicolor brand Xb6  (CGM4140COM) to the Arris brand XB6 (TG3482G) resolve this?    In other words, does the Arris XB6 have a reputation for working better with MoCA than the Technicolor XB6, or is it just something with the XB6 in general (such as using Docsis 3.1) that is causing the problem?  

 

Highlighted
Expert

Re: XB6 Gateway and MoCA - Any Difference between Arris and Technicolor

I'm not persoanlly sure if the XB7-A performs any better than the -T on MoCA performance, but i know how you feel. I had the same issue when I had my XB6-T, but it wasn't as bad as yours. It started out really bad, but then it improved over time, and firmware updates.

 

Every so often, those Actiontecs get kicked off and come back onto the network after a couple minutes. Eventually mine would stop connecting to it altogether, making me have to reboot them to reconnect them. Tried it without X1 in the mix (just as a test), same result. I looked at the MoCA Diagnostics page of the gateway of the XB6-T, it would show a low uptime. Ideally, the MoCA uptime should be pretty close to the uptime of the whole gateway itself. It's as if the XB6-T MoCA interface is randomly resetting itself, causing MoCA connectivity issues.

 

I currently have the XB7-T now, and so far, it has no issues (knock on wood)

 

How's the "Preferred Network Controller" option set?


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: XB6 Gateway and MoCA - Any Difference between Arris and Technicolor

The box on the 10.0.0.1 page is checked "yes", if that is what you are asking.

 

The MoCA mesh diagram on the 10.0.0.1 gateway page, which has 11 items on it, shows connections with minimum 503 with most in the 800 to 1600 range.   Incidentally, I could never get this mesh diagram to work with on the 10.0.0.1 page with the old XB3 - it always timed out, and the page took forever to do anything.  At least with this new gateway 10.0.0.1 works really well. 

 

Every time I run a speed test on one of the computers using MoCA adapter it seems to be working at full speed.  But the family complaint index has gone up about connectivity so I know there are issues we didn't have before this new gateway.

 

I'm going to try swapping out the Technicolor for the Arris and see if it makes any difference.  Since Comcast is a member of the MoCA alliance and uses it for X1, and Actiontec is probably the largest MoCA adapter provider, you'd think they would have worked all of this out.  The x1 boxes should use their channel, and the actiontec devices should use a different one.

 

Highlighted
Expert

Re: XB6 Gateway and MoCA - Any Difference between Arris and Technicolor

I would try to see what those MoCA Adapters are doing while the connectivity issues are happening, just to see. Persoanlly, i just feel its either a firmware issue on the XB6, or bad parts for MoCA were used on the gateway.

 

You may notice if you scroll up on the MoCA diagram page and see "Link Uptime" and compare that to the uptime shown on the "XFINITY Network" tab, it might show you a large discrepency in uptime.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!