Community Forum

WiFi is a NIGHTMARE. What have I missed?

Highlighted
New Poster

WiFi is a NIGHTMARE. What have I missed?

When we all started working from home because of the pandemic, I started to notice WiFi speed stalling rather regularly. I contacted Xfinity and they recommended upgrading our plan. So we went from 600 mbps to 1 gig.  It's been a complete and total nightmare ever since & I'm at an absolute loss of what else to do except for calling Verizon & switching to Fios.

 

Speed from the street to the modem seems consistently fine. But every day our WiFi from the modem to devices seems to degrade more and more. First the problem was localized to my laptop. Then my husband's devices started to have issues. Now the television set is crashing multiple times a night, and our Amazon Echos keep losing their WiFi as well. I thought our kid was the only one with a solid WiFi experience. But she just admitted she regularly hotspots to her mobile phone because our WiFi stinks so bad. 

 

We had an Xfinity technician visit last week. He felt the location of our living room was the problem (it's also the location of my temporary home office). Our living room does not have any ethernet or cable ports. The closest location for the modem is about 15-20 feet down 5 stairs and around the corner in the hallway.  The technican recommended installing 3 xfi pods, which we did.

 

I'm currently sitting within 2 feet of one of those pods and my connection has been dropping out every 30 minutes or so for 20-30 seconds at a time all morning long. Plugging my laptop into the pod's ethernet port actually made it worse. 

 

The technician also suggested that maybe my laptop doesn't have a strong enough antenna. So at this recommendation I bought a dual band antenna adapter for my laptop that's rated to 1200 mbps. Despite having very strong signal strength coming off my laptop now, I'll be darned if I can keep the WiFi going consistently. The best speed I can get to my laptop is around 55 mbps. But it's bottoming out to 5-10 mbps regularly.

 

For 3 nights in a row, the television has also started crashing and losing its signal, as well. This happened off and on over the duration of 2 hours last night. WiFi to the television dropped eight times. Last night's call to Xfinity tech support (our 4th call in a week), wasn't much help. We got the same advice we always get. "Reboot the modem. Reinstall the pods." 

 

I'm rebooting this thing 2x day at this point. 

 

We live in a 1400 square foot house. From the living room, I descend 5 stairs and take 7 steps and I'm standing right in front of the modem. It's not like this thing is located on the opposite side of the house. Yet I can't pick up a consistent signal in our living room? 

 

What else can we try to fix thing? What have I missed? And when is it time to throw in the towel and decide that this option just doesn't work for our internet needs?