Community Forum

Weak WiFi signal.

Highlighted
Regular Visitor

Weak WiFi signal.

Recently my wifi signal has been really weak its usally around 200mbps but recently i noticed it clocks in around 30-40mbps. Ive had a few issues with outages(both cable and internet) in my area but other than that nothing has changed the modem/router is in the same place and i havent added anything to my network. I have tried rebooting the modem/router which seems to do the trick for about 10 minutes then it goes back to 30-40 from the usual 200ish. i have had the modem/router for about 3 years( Arris TG1682G) I am wondering if it is a hardware problem i was already thinking of purchasing my own router and modem as the cost of $14 a month to rent just doesnt make sense but i want to make sure i wont have the same problem with the new equipement before i purchase. ive tried calling Xfinity and i get the usual cookie cutter "have you tried rebooting" , "have you made any changes to the network" and "we can send someone out to look at it but if we find everything is ok on our end you will be charged a fee" anybody have any ideas on what the issue could be?

Highlighted
Expert

Re: Weak WiFi signal.

For a test, does a computer hardwired directly to the 1682 with an ethernet cable have the same problem ?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Regular Visitor

Re: Weak WiFi signal.

I think i figured it out i turned on their new advanced security feature a few weeks ago thats when then problem started so i turned it off and bingo im back up to 200+ mbps. Not sure if its coincidence or not but im goint to keep an eye on the speed the next few days to see if it dips at certain times or remains the same throughout the day now.
Highlighted
New Poster

Re: Weak WiFi signal.

Can you tell me what "advanced security feature" you disabled?
Highlighted
Expert

Re: Weak WiFi signal.


@Skimima wrote:
Can you tell me what "advanced security feature" you disabled?

https://www.xfinity.com/support/articles/using-xfinity-xfi-advanced-security



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!