Community Forum

WP-4530 Printer Wireless Connection

New Poster

WP-4530 Printer Wireless Connection



A couple of weeks ago, the wireless devices in my house were experiencing intermittent connectivity issues to my modem. I called Xfinity Support and they sent me a replacement modem as a solution. When I set up the new modem using the Xfi app on my phone, I was able to transfer my password, devices, settings, etc. over to the new modem. All of my devices are now working except for my wireless Epson WP-4530 printer. This printer is in the same room as the modem and was working prior to my modem switch. I've taken my wireless devices (my laptop and my phone) to my office and have been able to print wirelessly on a printer at my office so the issue seems to be with my printer.


I've tried some troubleshooting options- restarting the modem, restarting the printer, returning the printer to default factory settings, entering my gateway information manually into the printer, I tried changing my network name on my modem and then entering the new name into the printer- so far nothing has worked. I've been through every possible setting on the Wi-Fi related setting on the printer and followed all of the steps only to get an error report each time.


When I print an error report on the printer, it states the issue is with the wireless connection.


Re: WP-4530 Printer Wireless Connection

The two WiFi bands have recently been combined into one with the Comcast gateway devices. Some devices get confused and don't know how to see / talk to combined bands.

If you are not using any Xfi Pods, you can try separating the 2.4 and the 5.0 bands and give them two different broadcast names / SSID's;

Associate the printer with the 2.4 band's SSID (broadcast name) and password.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!