Community Forum

Very slow upload speed, 1Mbps

Highlighted
Regular Visitor

Very slow upload speed, 1Mbps

I've been experiencing a very slow upload speed for a couple of weeks.

I also upgraded from Performance to Extreme Pro a week ago.

 

Download speed is limited to 300Mbps, which is understandable since I'm still on my old DOCSIS 3.0 modem.

 

But my upload speed is a measly 1 Mbps. I can't do any video-call, let alone gaming.

 

I've been on chats or phone calls many times with the agent, and what they can do is just restart the modem or do "troubleshooting" on their side. I've also power-cycled, plug-unplug the cable from the wall, and other basic troubleshooting.

 

Here's the modem status page https://imgur.com/a/yWxUsFa

 

Please help.

Highlighted
Regular Visitor

Re: Very slow upload speed only 1Mbps

Update: I'm getting 13 Mbps upload at 1am.

So I'm guessing the pipe could be congested during the day, and upgrading my modem won't help.

But does that even make sense that the pipe is congested when I can still get hundreds Mbps download, but only ONE Mbps upload?

ONE Mbps upload is not usable at all!
Highlighted
Expert

Re: Very slow upload speed only 1Mbps

FWIW. The upstream / return path "pipe" is much smaller than the downstream / forward path pipe is, so it is more easily saturated.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!