Community Forum

Upgraded to 600 Mbps, my speed went from 80 Mpbs to around 30 Mpbs

Highlighted
New Poster

Upgraded to 600 Mbps, my speed went from 80 Mpbs to around 30 Mpbs

My xFi Gateway modem arrived today.  I did the following:

- disconnected my motorola surfboard JRSB6120

- disconnected my wifi router

Performed the "Follow these steps to activate your xFi Gateway"

  - downloaded the xFi app on my phone

  - opened the app, signed in

  - followed the steps

 

Everything worked just fine.  The XFi activated, I can manage and see devices on my home network connected to it.

 

My plan shows that I have a 600 Mbps download (15 Mbps) upload PLAN.  But I am only seeing speeds of max 33 Mbps down (15 Mbps up is working).

 

Prior to the installation I was getting 80 Mbps down and 6 up (matching my plan).

 

I spent an hour on chat with xfinity and was disconnected at the end and asked to do a survey.  With no resolution.  Cannot reach a live person.

 

I have power cycled the modem several times and waited for start up.  Speed results are consistent.

 

Is there a way to factory reset the device and re-activate?  Is there a way to reach a live person to actually check the speed on the xfinity end? 

 

Thanks.

 

 

Highlighted
Official Employee

Re: Upgraded to 600 Mbps, my speed went from 80 Mpbs to around 30 Mpbs

Hello. Thank you for reaching out. My apologies that you're experincing issues with degraded internet speeds. Speeds can vary depending on a number of factors - number of devices connected, your device's capabilities, age of the device, interference in the WiFi signal, etc. If you would like further assistance, please send my a private message with your full name and account number. Please do not post any personal information in the forum. We look forward to getting this issue resolved for you. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!