Community Forum

Upgrade from 75mbps to 400mbps over a week ago, no increase in download speed.

Highlighted
New Poster

Upgrade from 75mbps to 400mbps over a week ago, no increase in download speed.

I upgraded my service from 75/5 to 400/10 a week ago and have yet to see an increase in speeds.

 

I am seeing a download speed of 90mbps when tested through speedtest.net

 

I am using a Arris Surfboard SB6190 > Orbi Router > netgear 5 port network switch to the device. All devices connected to the switch and wifi networks are receiving the same speeds.

 

I have spent 4-5 hours on calls with support lines and in the brick and mortar stores with no resolution in sight. I would prefer to keep my modem as its one of the approved options for the plan I have and I would like to avoid renting a modem from Xfinity as it offers no added functionality to the service over the one I currently own outside of Docsis 3.1 which I would not be taking advantage of with a 400/10 plan.

 

Any assistance would be greatly appreciated.

Highlighted
Expert

Re: Upgrade from 75mbps to 400mbps over a week ago, no increase in download speed.

For a test, what speeds do you get with a computer hardwired directly to the SB6190 ?

 

What is the upload speed ?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: Upgrade from 75mbps to 400mbps over a week ago, no increase in download speed.

The upload speed when connected to the modem directly is still 10mbps upload

Highlighted
New Poster

Re: Upgrade from 75mbps to 400mbps over a week ago, no increase in download speed.

The upload speeds are also consistent @ 10mbps on my phone, when using my PC through the switch (hardwired Cat5e), through the Orbi router. The download speeds also are consistent @ 90mbps on all devices regardless of configuration.

Highlighted
Expert

Re: Upgrade from 75mbps to 400mbps over a week ago, no increase in download speed.

What is the model number of the Netgear switch ?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: Upgrade from 75mbps to 400mbps over a week ago, no increase in download speed.

GS605v5

Highlighted
Expert

Re: Upgrade from 75mbps to 400mbps over a week ago, no increase in download speed.

O/k that's a gigabit capable switch so that's not the problem.

 

Try calling 1-800-comcast and ask a rep to completely remove the modem from your account and to "re-provision" it from scratch. Also ask them to confirm that the provisioning and account data in their database is correct and complete and that the correct configuration / bootfile for your subscribed to speed tier is being pushed to the modem.

 

Good luck !



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!