Community Forum

Unfixable? Slow Speeds

Regular Visitor

Unfixable? Slow Speeds

I have a problem that seems to be a common one. I pay for the 200mbps download speeds. I can only ever achieve roughly 90mbps on average. Often slower in the 70-80 range. This is for any device. This has been like this since I had changed service to add Television to my package years ago. I have been with Comcast forever, literally. I first brought cable Internet in when the service was owned by @home. No throttle on this servive. Along the years, @home was sold off and eventually arrived with Comcast. During some initial troubleshooting that has to go back 10 years, one technician commented that he was amazed that I had no filter or clamp on my speeds. Many years later after adding TV, my entire neighborhood hit the limit where nothing but pixelization was present on any TV signals. After a month of conversations with Comcast, they sent out a crew of 8 or more trucks and line crews and ran new runs from the end of the node back. TV became better, but I now had a throttle and speeds dropped down to 90mbps at that point.

 

Fast forward this 10 years now. I have entirely upgraded my internal network. I run a Netgear CM600 with DOCSIS 3.0 and 960MBPS max. speeds. No improvement. I upgraded to the latest Linksys AC1900 router along with a 2nd ASUS RT-AC3200. All gigbit equipment. I even replaced my switch. I had an old Linksys gigbit switch that I upgraded along the way with hopes of improvement. My wired or wireless speeds are the same. Of note, when going modem direct to my laptop with a gigbit card, the speeds remian at the 90mbps range. Within teh last month, I had a tech out for poor TV reception. He rewired everything and replaced the splitter to a monster block about 10" square. Every connection was re-run and new runs made in some cases. He was complete as possible with checking levels at every interface. When we got to the download speeds, he again checked everything on my end and could not resolve any improvement or make any improvements.

 

Going modem direct certainly implied not on my end. Interestingly enough, my neighbor next dooe gets 150mbps down on a slower package and the absolute last home on our node. I have even ran a new cable directly from the outside box through my window directly to the modem without impacting any change. That connected nothing else other than the modem. Every device in my home reports the same speed results either wired or wireless. The tech that came out suggested there may be a very old clamp or filter somehwere in the line likley at the pole or elsewhere only on my drop. Or possibly, there is some disconnect on Comcast's side that never removed or changed the throttle for my speeds after upgrading to the 200mbps package. So my result is literally years of this frustration of my family complaining about inability to stream without buffering, slow internet on their phone or tablet etc.

 

The bottom line is that I have upgraded and am paying much more for this package and I am not getting what I am paying for. I am about at the point where I have no faith that Comcast can resolve this. Over the years probably 10 different techs have tried and now I think dumping Comcast may be my only option as nobody seems willing to take on the challenge to fix what seems to be unfixable A change in provider may be my only solution. This forum post is now my last attempt to try and fix this.

 

BTW, all modem signals ar rock solid (Power, SNR etc.. All within ranges. Almost nominal to the letter). I have read hundreds of articles, reset modems and router hundreds of times, reset back to facotry defaults, changed Wifi channals and just about everything else anyone suggests. The bottom line is modem direct is same as full network connected and even fresh cable run.

 

One last note, I tried replacing all of my network cables from cat 5 to cat 7. Of course no improvement there either. Also on my Netgear CM600, I started with the Comcast modem and was at 90mbps and this purchase was an attempt to improve the speeds. I have probably $3000 invested in the best routers, solid modems, cables, upgrades peed packages etc.  So who out there is going to be my hero and find my problem?? I will try anything at this point. I hate to have to switch providers

Regular Visitor

Re: Unfixable? Slow Speeds

No help? Nobody has any ideas?

Frequent Visitor

Re: Unfixable? Slow Speeds

Make sure there is not a setting in the router slowing the speed. Turn qos off to make sure.
If using window 10, download the ookla speed app from the Microsoft app store and test speed with it. It takes any browser interference out of the equations.
Regular Visitor

Re: Unfixable? Slow Speeds

Thanx for the response. Qos is off. Xfinity speed test shows equal to Ookla within a few %. I typically opt for Ookla and have the app installed on all devices. I just upgraded to Windows 10 Pro, but speeds are the same on 7 Pro and even an old programming laptop I use that still uses XP. I have tried different frequencies on the modem with notable change in levels of power or SNR. Certainly no speed changes. Routers are out of the equation as modem direct to PC results in identical speed results. Thanx again for the suggestions