Community Forum

URGENT: VPN not working

Highlighted
New Poster

URGENT: VPN not working

VPN was working until a few days ago when I restarted my comcast box. I need VPN to connect to my computer at work however ever since the restart, VPN fails to connect. I can connect to my work VPN from home just fine using mobile hotspot from my TMobile phone however I would like to use my WiFi for this. Following is some more information:

 

Network infrastructure: Arris TG1682G

 

What I have tried:

1. Called Comcast customer service: the recording never lets me speak to tech. support since it keeps triggering a modem reset promising me it'll let me talk to a real person after the reset. I have lost count of the number of reset loops I have been put through.

2. I am using Windows 10 and have switched off all firewalls. It is not an issue on my end since everything works fine with my phone's hotspot as I mentioned earlier.

3. Disabled xFi Advanced Security.

 

And yes, I have read https://www.xfinity.com/support/articles/using-a-vpn-connection.

Highlighted
Regular Visitor

Re: URGENT: VPN not working

Having the same problem. All was working fine for months, then it stopped.

Highlighted
Regular Contributor

Re: URGENT: VPN not working

Some Vpns have a kill switch, it blocks internet traffic if it loses its connection, you  rebooted your Comcast box so it lost its connection, try rebooting your window 10 box and restarting the the vpn, just a thought as a had a similar issue

Highlighted
Regular Visitor

Re: URGENT: VPN not working

Thanks, but tried that already. Rebooted both the machine and the Comcast box, but it made no difference. A secondary machine on the network CAN access via VPN./ But my primary machine,  which had been able to access VPN for months, can access if I set up by phone as a mobile hotspot, but can no longer access using the same network it had been using. Nothing in the machine or VPN configuration has changed.

Highlighted
Regular Visitor

Re: URGENT: VPN not working

I have the same issue. Tried disabling the advanced features. Doesn't work.

IT workedgreat until a few days ago. I didn't change anything.

VPN is working with hotspot

Highlighted
Regular Visitor

Re: URGENT: VPN not working

Exactly. Comcast has been no help.
Highlighted
Regular Contributor

Re: URGENT: VPN not working

Try using a different Vpn server location, mine quit working and changed location and it worked fine after the change

Highlighted
Regular Visitor

Re: URGENT: VPN not working

I have three vpn servers at my office. All were working fine until this problem. All are working fine if I set up a mobile hotspot. If I power down the router, vpn will sometimes work as soon as the router powers up, but not if I try to connect a second time, and not if I wait a while before connecting.
Highlighted
Regular Visitor

Re: URGENT: VPN not working

I contacted my vpn adminstrator and he can't reproduce the problem. He suggested to contact Comcast/Xfinity. 

Haver you tried contacting Comcast?

Highlighted
Regular Visitor

Re: URGENT: VPN not working

We have contacted Comcast. They said restart the router. No help.
Highlighted
Regular Visitor

Re: URGENT: VPN not working

I'm still debugging. I think it might have to do with the geographical location. I'm in Oregon and my vpn is in California. Are you in the same state? Just trying to find the root cause.

I also use my own router now, changed the LAN addresses, used a direct port. No luck so far......

Highlighted
Regular Visitor

Re: URGENT: VPN not working

Yes, I am in the same state as ths vpn.
Highlighted
Regular Contributor

Re: URGENT: VPN not working

I use expressvpn as my vpn, and I used my own router for a while and it would change the dns on my device and sometimes I would have to reset it after rebooting, just a thought

Highlighted
Regular Visitor

Re: URGENT: VPN not working

Thanks. I'm am using my employer vpn, which assigns the ip when connection is made. Resetting my router has no effect.
Highlighted
Regular Contributor

Re: URGENT: VPN not working

I had to reset the dns on my device, not the router

Highlighted
Regular Visitor

Re: URGENT: VPN not working

Yeah, I have done that too.
Highlighted
Regular Visitor

Re: URGENT: VPN not working

Ok, I fixed it. Don't completely understand why, but it's working now.

What did I do:

 

1. Use my own router, (make sure that your primary PC uses this router)

2. Enable bridge mode on my Xfi box

3. Change the router IP address from 10.0.0.0. to 192.168.0.1

4. Add a port to the XFI box: port 1723 and select TCP

 

I'm not sure if all four things are needed, but it solved my issue