Community Forum

Speeds way lower than I pay for

Highlighted
New Poster

Speeds way lower than I pay for

I pay for 1 gig internet speeds and when I do speed tests, I get speeds way lower than that -- often in the 100-150 mbps download. This is ridiculous, I am paying for the fastest and getting the lowest. I tried to speak with someone online and they just kept sayin my modem doesn't support 1 gig speeds. Which is false, because I bought a modem and router that support speeds higher than 1 gig. Even if the modem doesn't support 1 gig, I should be at least getting speeds in the 600s I would think! Please help me get this corrected. Thanks 

Highlighted
Silver Problem Solver

Re: Speeds way lower than I pay for

https://forums.xfinity.com/t5/Your-Home-Network/Gigabit-speed-troubleshooting-video/m-p/3310454#M316...


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
Regular Contributor

Re: Speeds way lower than I pay for

Please note that you are discussing throughput (bytes/sec) not speed (distance/time).    Regardless, we can't advise you much unless you describe the test scenario in detail.   Is there some actually-useful application that is performing inadequately or are you a wicked fiend for benchmarking like me?   :).    Consider to downgrade your service intentionally to the point at which one of your crucial use-cases/apps degrades unnacceptably.   Then bump the tier up one level from that.    

Highlighted
Expert

Re: Speeds way lower than I pay for


@denn22 wrote:

I pay for 1 gig internet speeds and when I do speed tests, I get speeds way lower than that -- often in the 100-150 mbps download. This is ridiculous, I am paying for the fastest and getting the lowest. I tried to speak with someone online and they just kept sayin my modem doesn't support 1 gig speeds. Which is false, because I bought a modem and router that support speeds higher than 1 gig. Even if the modem doesn't support 1 gig, I should be at least getting speeds in the 600s I would think! Please help me get this corrected. Thanks 


What are you getting for the upload speed ?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!