Community Forum

Slower than advertised speeds recently

Highlighted
Frequent Visitor

Slower than advertised speeds recently

I've been on the 300Mb/s down speed for awhile and used to regularly see numbers right at that 300 down mark, but I just decided to run some tests this week and I'm seeing numbers closer to 150-200 down when testing via xfinity's own speedtest.

What sorts of things should I be looking at to get this addressed?

Highlighted
New Poster

Re: Slower than advertised speeds recently

Same here. usually runs at 240mbps, today 1.5mbps.

Highlighted
Frequent Visitor

Re: Slower than advertised speeds recently

In a slightly crazy turn of events, a guy from Comcast called me out of nowhere (I had not called them at all) and said he was in my driveway and wanted to check and maybe replace the line between the box and my house.  He suspected a leak/break.  He just left and my speeds are about 220 Mb/s down, which is a slight improvement from what I had, but still nowhere near the 300 Mb/s I should be getting. 

 

Downstream SNR is about 40.2 dB on each of the 16 downstream channels

Upstream Power is 43.8, 45.3 and 45.0 on the 3 upstream channels

Highlighted
Frequent Visitor

Re: Slower than advertised speeds recently

Wow....that's not even close to acceptable.  Maybe I shouldn't complain about my speed.  Good luck getting back up and running.

Highlighted
Frequent Visitor

Re: Slower than advertised speeds recently

Ok, I think I sorted out my own issue.  It looks like my router had some sort of traffic analyzer turned on.....that seems to have slowed things down quite a bit.   Once I turned that piece of rubbish off, my speeds went back to normal although I do still get better speeds when I connect directly to the modem with no router, so I think that means I'll be getting a new router sometime soon.