Community Forum

Reserved IPs, Network issues

mudoch
New Poster

Reserved IPs, Network issues

I have the router model CGM4331COM, I do have 2 reserved IPs listed but I found out that certain devices that had reserved IPS are not listed asny longer.  EG 10.0.0.10-12 are known reserved IPs but no longer show in the list also the devices still connect to the net but are now assigned DHCP (last IP 223 and 81). These two devices are my mesh WIFI network.  Although DHCP works I really perfer these 3 devices reserved so I can log into them for firmware updates.

 

WHat I've done so far is log into the Xfi router and tried to add reserved I get the error the IPs have a device assigned.  But then I can't remove the old reservation(s) as they are not listed in either the connected or not connected lists. The one device RBS50, connected, shows assigned 10.0.0.11 but is listed as DHCP. RBR50 should be reserved as 10.0.0.10 but is DHCP assigned 10.0.0.223. Selecting edit for the device and selecting Reserved IP and entering an IP desired after abourt 30 seconds gives Failure!  Leaving the offered IP gives the same Failure! message.

 

I also have a software application that must be found by IP so a DHCP ip will not work for those computers. The application is a TCP/IP host and the client is unable to use hostname.

 

Now as for the netowrk issue:

 

For the last 2 days around 2am my whole network goes out. I have to manually reset the Xfinity router to get things back online. Xfinity router does reconnect just fine but everything, Printer, mesh AP netowrk, tablets are unable to find XFi network. More annoying is that the MESH AP (RBR50) is connected via Ethernet cable (port 4) to XFI router. So why this drops off makes no sense. This just started this week.

jlavaseur
Valued Contributor

Re: Reserved IPs, Network issues

If your gateway was configured as mine was, the dhcp range started at 10.0.0.2, so if you want the ip you have listed, you will have to edit your dhcp to start will something like 10.0.0.15, I did from the admin panel by login to 10.0.0.1

mudoch
New Poster

Re: Reserved IPs, Network issues

So the reserved IP options in the router are now defunc just left overs? 

 

The point of reserved IP is to leave DHCP on for a wide range and then tell the router that if MAC x:x:x:x:x connects give it IP y.y.y.y  unless something else has leased it. 

jlavaseur
Valued Contributor

Re: Reserved IPs, Network issues

The way I do it is set a static ip for the device I want to have that ip, that way the ip never changes,  dhcp still works

mudoch
New Poster

Re: Reserved IPs, Network issues

Yes, I've done that part  but DHCP can still assign that IP, reserving it prvents network clashes.

The problem is I should not have to.  The router offeres Reserved IP settings but then fails to assign any.  It makes no sense.  Last month the router allowed me to do this but now stopped.  Comcast support was just not helpful.... Seems I got the person too green to understand.

jlavaseur
Valued Contributor

Re: Reserved IPs, Network issues

I am not familiar with the mesh thing but, static ips and reserved ips each pull from a different ip range, static ips are set manually and can't be in the set dhcp range, reserved ips have to be in the set dhcp range, as far as I know your can only set one or the other, so if you set a static ip, there can never be a conflict, as it's not in the dhcp range, there for the dhcp server can't attempt to assign that ip, I can be wrong but i always did things this way and never had a problem or conflict of any kind,

Also when a device connects and is assigned a dhcp ip, it gets a lease also, so with that lease it reserves that ip for that device for the duration of the lease, I think the default lease duration is 5 days, or there about, you can set the lease duration time in the gateway, so I am not positive, but the lease probably doesn't show up anywhere, so that might be why you get the already assigned error, because there is a lease involved, I personally set the lease time to forever, so the ip never changes, but hey that's just me being lazy