Community Forum

Repeated Internet failure, many times a day, for months

Highlighted
New Poster

Repeated Internet failure, many times a day, for months

Four or six months ago – I don't remember when – one day my Comcast/Xfinity Internet connection quit. I dutifully reset the modem, and it came back up. 

 

Then a few minutes later it quit again. According to the modem's lights, it immediately began reestablishing the connection, so I waited. It was successful, taking about five minutes.

 

Then a little while later – 10, 15 minutes? – it failed again. And reconnected again.

 

I called Comcast, and a robot told me to reset the modem. Of course, I had already done so, but I did it again. The connection was reestablished, but then failed again in ~10 minutes.

 

The connection reestablishes automatically every time, but not because the modem was reset. The connection fails FROM COMCAST. But I couldn't get this fact through to the robot. Nor could I find any way to talk to a real human with a brain. 

 

So I gave up. This intermittent problem has continued since then, for months now. The connection will be okay for a day or two or three, sometimes up to five, but then it will fail repeatedly a dozen or more times in a day. It always comes back up on its own – without the necessity of resetting the modem. But of course it takes 5 minutes or more to reestablish connection. 

 

I also have a spare modem; I've tried switching, but the same problems occur with it also. Both modems are mine; they are basic (Zoom Telephonics 5341J), as my needs are simple. Both are on Comcast's approved list (made sure before I bought them). Both have worked okay for several years. 

 

I have a chronic illness which considerably impairs my activity. I haven't had the energy – or the time, with all the things I have to do just to get through the day – to deal with this problem. So I've just endured it. Sometimes it's fine for a while – up to 5 days or so – but usually when it does go down, it'll do so for maybe a dozen times in a day, for several days in a row. There's no clear pattern. Sometimes I'm up in the middle of the night, and it goes down then. 

 

MacOS has (had) a Network Diagnostics utility, which shows the status of each point in the connection chain. When the connection is down, it shows ISP as good, but Internet and Server as failed. There's a connection to Comcast, but no communication happening. 

 

This morning the Comcast Internet connection went down, and didn't come back. I called Comcast support, and the robot told me there was an outage in my area, and the service was expected to be restored by 1:30pm. Did I want to be notified? I said yes, send a text; it said it would. 

 

Not having received the promised notification, I texted OUTAGE as instructed, and received a message that indicated service had been restored. So I turned on the modem, and indeed it was working again. But then within 10 minutes it failed. 

 

I called Comcast support again, and the robot told me to reset the modem. I said I had already done so (which I had, and switched modems as well). But the robot is too stupid to hear that; no matter what I said, it kept on with variations of "Reset your modem. If you don't know how, I can send a text." Etc. etc. Maddening. 

 

Robot said if I reset the modem, it would check my line again in 10 minutes. Of course, if it's working then, the robot will assume everything's fine. Then the connection will quit again, and I'm back where I started. 

 

Connection failed again in another ten minutes or so. And again. And again. And again. 

 

So for four to six months now, I've had unreliable Internet service for ~3 days out of each week. But of course I'm paying the full premium for the service I'm not getting. And this month Comcast raised my rate by 25%, as my initial discount period has expired. Insult to injury. 

 

Anybody have any suggestions?