Community Forum

Re: Internet speed tops out at ~190 for Extreme Pro

Highlighted
New Poster

Re: Internet speed tops out at ~190 for Extreme Pro

I recently upgraded to the Extreme Pro as well.  I was promised speeds up to 600 when they called me to sell me this new package.  I rebooted the modem, then they also sent a new signal.  I have tested speeds on both channels of the wifi router and also hard wired directly to modem and cannot get speeds over the 130's.  The modem is an ARRIS SB6190 and I was getting mid 200's before this switch.  From what I have read, this modem should be able to process faster speeds.  I have tested these speeds on my 5Ghz channel of the router which is a Linksys WRT3200ACM and it is the same speeds as hardwired.  

I have a 30-day period to cancel this and I am really thinking about cancelling because this seems to be a common issue.  

Highlighted
Expert

Re: Internet speed tops out at ~190 for Extreme Pro

Try calling 1-800-comcast and ask a rep to completely remove the modem from your account and to "re-provision" it from scratch. Also ask them to confirm that the provisioning and account data in their database is correct and complete and that the correct configuration / bootfile for your subscribed to speed tier is being pushed to the modem.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!