Community Forum

Re: Gigabit Speed Problems with XB6 Modem

Highlighted
Regular Visitor

Re: Gigabit Speed Problems with XB6 Modem

I totally agree that Xfinity does not know what they are talking about. Here is my experience: I am sick of them saying it must be my equipment and they get 900 mbps, etc. same as you heard. One of the worst ever!  What is wrong with XB6 Modem is the question of the week???

 

With Xfinity, I went from 300-400 Mbps (WI-Fi) not hard-wired with the old router (XB3) with a plan of Extreme for over 4 1/2 yrs. ($139.00 month) Perfect!  There was no need to go to the XB6 nor Extreme Pro or 1000 mbps plan.  It worked for me for almost 5 yrs.  Since I moved into this building. 

 

Then Sunday a week ago my speed dropped to between 17-30 Mbps out of nowhere!

 

I am a web designer so it is imperative I have a min of 250 mbps in order to work with my websites (they have a lot of graphics, videos, podcasts - for author clients and I am a blogger).  Otherwise, they will not even load. 

 

After spending 12 hrs on phone with Xfinity, they sent someone out and brought me a XB6 modem.  Hardwired I got 92 mbps max!!!  Wi-Fi was getting around 100mbps ONLY! Then it is intermittent from Wi-FI from 12-125 mbps. The technician had no clue. I live in a high-rise downtown on the top 15th floor in a small studio which is less than 600 sq. ft. and steps from the modem.   

 

All my devices are up to date, drivers, and the speed for my laptop shows 433mbps. I even purchased a new 7000 series Dell laptop which will not arrive until Jan 2, 2020 (since they kept saying it must be my Dell, even though Dell said it was pefect).

 

Xfinity sent someone else out to rewire. After the rewire, once again nothing!!!.  He left and never checked anything.  My ipad pro, iphone 7 plus all get over 350mbps, but my year old Dell, Gateway, ipad Air and Kindle Fire HD, are all running less than 20 mbps.  All these devices were soaring before with XB3. Never one problem for 4 1/2 yrs.  until a week ago. 

 

Behind on work, totally frustrated, I call Xfinity back. They send someone else out yesterday. I finally got around 150-200 Mbps but that is ALL! WAY SLOWER THAN BEFORE. Plus they charge you $15 rental. But I am not satisfied and tell him to try another one. 

 

SO, he changes it out to yet another XB6. This one gets 12-25 Mbps! Even hardwired.  I told him this was unacceptable! I needed to at least put back in the previous one. He refused and a bad attitude - and left and took my other good box.

 

He was on the cell phone the entire time talking about personal stuff. He did not seem to know anything.  I had to show him how to look at the network settings.  He did not know anything! So he left me with a bad XB-6!  Said it must be the building.  Oh sure, after close to 5 yrs I need to move because you cannot get it to work??

 

Now I get 17 Mbps WiFi and 20 Mbps hard-wired. I am not able to work. I spent another 5 hours on the phone with Xfinity to see if I should upgrade to the 1000 Mbps plan if it would make a difference.  These people are all clueless.  But it took them so long with the open work order and transferred 6 times and then the call was disconnected! DISCONNECTED. A nightmare. 

 

Finally called back and got a supervisor at Xfinity and he is sending someone else out on Wednesday.  So I have spent more than a week on this, behind on work, and getting nowhere! Do not have a lot of faith it will correct.  He said they would waive the fee.  Why wouldn't you?  Your fault.  

 

Also, the XB-6 box runs very HOT!

 

I am going to Costco or Best Buy today and buy my own router and see if this works  (I do not have TV, only internet and entertainment streaming package). Going to try it before he comes on Wednesday to see what happens. I will keep you updated. At this point, I very unsatisfied with Xfinity! 

 

Any help will be greatly appreciated!    

Highlighted
Silver Problem Solver

Re: Gigabit Speed Problems with XB6 Modem


@JudithDCollins wrote:

I totally agree that Xfinity does not know what they are talking about. Here is my experience: I am sick of them saying it must be my equipment and they get 900 mbps, etc. same as you heard. One of the worst ever!  What is wrong with XB6 Modem is the question of the week???

 

With Xfinity, I went from 300-400 Mbps (WI-Fi) not hard-wired with the old router (XB3) with a plan of Extreme for over 4 1/2 yrs. ($139.00 month) Perfect!  There was no need to go to the XB6 nor Extreme Pro or 1000 mbps plan.  It worked for me for almost 5 yrs.  Since I moved into this building. 

 

Then Sunday a week ago my speed dropped to between 17-30 Mbps out of nowhere!

 

I am a web designer so it is imperative I have a min of 250 mbps in order to work with my websites (they have a lot of graphics, videos, podcasts - for author clients and I am a blogger).  Otherwise, they will not even load. 

 

After spending 12 hrs on phone with Xfinity, they sent someone out and brought me a XB6 modem.  Hardwired I got 92 mbps max!!!  Wi-Fi was getting around 100mbps ONLY! Then it is intermittent from Wi-FI from 12-125 mbps. The technician had no clue. I live in a high-rise downtown on the top 15th floor in a small studio which is less than 600 sq. ft. and steps from the modem.   

 

All my devices are up to date, drivers, and the speed for my laptop shows 433mbps. I even purchased a new 7000 series Dell laptop which will not arrive until Jan 2, 2020 (since they kept saying it must be my Dell, even though Dell said it was pefect).

 

Xfinity sent someone else out to rewire. After the rewire, once again nothing!!!.  He left and never checked anything.  My ipad pro, iphone 7 plus all get over 350mbps, but my year old Dell, Gateway, ipad Air and Kindle Fire HD, are all running less than 20 mbps.  All these devices were soaring before with XB3. Never one problem for 4 1/2 yrs.  until a week ago. 

 

Behind on work, totally frustrated, I call Xfinity back. They send someone else out yesterday. I finally got around 150-200 Mbps but that is ALL! WAY SLOWER THAN BEFORE. Plus they charge you $15 rental. But I am not satisfied and tell him to try another one. 

 

SO, he changes it out to yet another XB6. This one gets 12-25 Mbps! Even hardwired.  I told him this was unacceptable! I needed to at least put back in the previous one. He refused and a bad attitude - and left and took my other good box.

 

He was on the cell phone the entire time talking about personal stuff. He did not seem to know anything.  I had to show him how to look at the network settings.  He did not know anything! So he left me with a bad XB-6!  Said it must be the building.  Oh sure, after close to 5 yrs I need to move because you cannot get it to work??

 

Now I get 17 Mbps WiFi and 20 Mbps hard-wired. I am not able to work. I spent another 5 hours on the phone with Xfinity to see if I should upgrade to the 1000 Mbps plan if it would make a difference.  These people are all clueless.  But it took them so long with the open work order and transferred 6 times and then the call was disconnected! DISCONNECTED. A nightmare. 

 

Finally called back and got a supervisor at Xfinity and he is sending someone else out on Wednesday.  So I have spent more than a week on this, behind on work, and getting nowhere! Do not have a lot of faith it will correct.  He said they would waive the fee.  Why wouldn't you?  Your fault.  

 

Also, the XB-6 box runs very HOT!

 

I am going to Costco or Best Buy today and buy my own router and see if this works  (I do not have TV, only internet and entertainment streaming package). Going to try it before he comes on Wednesday to see what happens. I will keep you updated. At this point, I very unsatisfied with Xfinity! 

 

Any help will be greatly appreciated!    


The first thing to do is to replace the XB6.

 

I am pleased with my XB6 for ethernet; I turned off wifi and I'm using an Orbi/two satellites for wifi.

 

Speednet shows me getting 889 down with my Win10/ethernet computer.

You should get at least that with the same configuration.

https://forums.xfinity.com/t5/Your-Home-Network/Troubleshooting-Gigabit-internet-speeds/m-p/3145413#...


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
Regular Visitor

Re: Gigabit Speed Problems with XB6 Modem

Thanks for the reply.  This is my second XB6 in a week.  The second one was worse than the first and he left me with it getting 17 mpbs!  When I had 300-400 mpbs (wifi) with the XB3!

 

So do you think I should try and get router and bridge,  like some others to help with the speed?   If so which one would you recommend to work best with the Xb6?  I read on a forum the reason the XB6 does not work at its capacity because it is a MIMO 4 x 4 and most of all our devices including cell phones are operating on 2 x 2?

 

Xfinity seems to know nothing about the problem.  Since I live in a hi-rise, all they do when they redid the wiring is just run a new cable.  They do not do anything outside.   

Highlighted
Silver Problem Solver

Re: Gigabit Speed Problems with XB6 Modem

Did you read everything here?

https://forums.xfinity.com/t5/Your-Home-Network/Troubleshooting-Gigabit-internet-speeds/m-p/3145413#...


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
Regular Visitor

Re: Gigabit Speed Problems with XB6 Modem

I solved the problem!!!  Everyone, please see the solution below.  YAY! 

 

I got rid of Xfinity's XB6 Modem!  After 5 techs, a total rewire and 3 different XB6 boxes which were giving me 50-92 Mbps WIRED and 17-20 Mbps WiFi!!  

 

As mentioned, I am a web designer and cannot operate less than 250 Mbps.  I have had 250-400mpbs for over 4 1/2 yrs with my XB3 Box. (WiFi).   Xfinity refused to provide me with another XB3 Modem (which I had previously)  Even after calling 3 supervisors and they assured me the tech would bring me the XB3.  When they arrived, the tech refused to do so.  These reps are very unprofessional. 

 

So after doing my homework, it appears in all the tech online publications it states XB6 modem does NOT work with any client devices that are out today.  NOTHING.  Because they have not been invented yet.  As the articles mention from the latest tech web sites,  Xfinity needs to take these off the shelf and STOP forcing these modems on customers.  Here is the scam they are running:

 

This is what they will tell you.  I have heard it so many times. They say it is coming out at 900 Mbps with their device, but they do not care that it does not communicate with anything other than another 8 x 8 MIMO (which is what the XB6 modem) is.  All the devices out there, even the latest iPhone, tablets, and laptops, etc. are either a 2 x 2 or a 4 x 4 MIMO, not 8 x 8.  

 

So until our world invents something to communicate and compatible with an 8 x 8 then Xfinity needs to take it off the shelf.  What they want you to do is force you to change to the 1000 Mbps plan and force you to get an XB6 modem, which again it will NOT work.  They make you think your devices do not work, which is totally incorrect.  So everyone is running out to buy something new and disappointed with no change. 

 

So what happens, it causes you to FLAT line.  I can see it.  Both my new 2019 Dell is 833 Mbps and my 2017 Dell is 433mpbs.  OK, the minute the XB6 modem is on, it takes my speed down to 17-20 Mbps. With my iPhone 7 plus and iPad Pro a little higher. 

 

So, I was so tired of spending hours every day for almost two weeks dealing with Xfinity (phone and in person).  I put in over 30 hrs of phone time with them and behind on work with all the visits and interrupted service. 

 

I contacted numerous supervisors and my case was escalated many times. No one listens, and they sent 5 techs out, totally unprofessional and clueless.  They were very rude.  They do not want the customer to know more than they do. 

 

Good NEWS!  I solved the mystery!!!   Take note everyone.  I proved the XB6 does NOT work.  I went to Best Buy and purchased a  NETGEAR - Nighthawk X4S Dual Band AC3200 Router with 32 x 8 DOCSIS 3.1 Cable Modem  (modem and router combo).  With the 2 yrs extended replacement warranty, it came to $387.32.  Went in and picked it up and back in a flash.  No waiting.  Even the rep at Best Buy said so many people are coming in complaining about the Xfinity XB6 Modems (he also reiterated, they are not compatible with any devices out today). Hence everyone is coming in to purchase an alternative. 

 

Came home and hooked it up.  I called Xfinity and activated it.  BINGO, out of the gate, 380 mpbs WiFi!!!!  It has even got up to close to 400 mpbs and I am on the Extreme plan (same plan I have been on for 4 1/2 yrs). It has been solid now for this past week.  DELIGHTED!  

 

So, I called Xfinity back, filed a complaint and it got several supervisor's attention and they finally listened and took down the entire story and I requested the last two techs which came out be terminated for their actions.

 

Since then, I have had their loyalty division and others from Comcast/Xfinity reaching out to me. They can see that by removing the XB6 modem and purchasing my own, the problem was solved.  Something they could not and apologized.  They admitted they have numerous problems with this XB6 Modem and constant complaints from customers, but yet they are still selling them.   Until I purchased my own to show the difference they would not listen. 

 

She took down every detail of my nightmare story, shocked and how I proved them wrong.  So you guys out there, do not get a router and keep XB6 Box.  Not necessary to do a bridge.  Just get the Netgear I referenced above which is a Router/Modem combo.  Now I do not have to deal with Xfinity's modem or pay the $15 rent.   I returned it online and dropped it off at their mobile store location and let them know the problem as well.

 

This was money well spent!  Very happy with my new modem/router. Hopefully, Xfinity will take notice and take these off the market until they are compatible with customer devices.

 

Glad this drama is over with so I can get back to work with great speed.  If there had been another web provider in my area I would have left Xfinity in a NY minute.  Horrible customer service. Please save yourself the trouble folks and buy your own router/modem.