Community Forum

Purchased gigabit internet - Only get ~280-320mbs using wired connection and all-xfinity gear

Highlighted
New Poster

Purchased gigabit internet - Only get ~280-320mbs using wired connection and all-xfinity gear

Hello,

 

I just recently became an xfinity user. I purchased the 1gbs plan for ~80 a month and am also using an xfinity gateway. I have never been able to get over 320mbs using fast.com's speedcheck (which I consider to be the only real test) and am capped at ~500 using xfinity's inflated internal speedcheck via the troubleshooting page on internet speed. I have switched cables (using cat5e and cat6, I have two lengths of each), restarted the gateway, restarted the computer, tried it wired up to my main pc and several of my laptops, ensured no one else is using the internet, etc etc etc.

I am using cat6 directly from the gateway into my computer. My computer isn't at fault because I went and tested it at my old apartment, which also had 1gbs, and routinely get ~750 on fast.com.

 

If Xfinity is unable to provide me with the service that I'm paying for that is fine, they just need to be honest with me so that I can stop paying for a service they can't provide. I haven't been able to even find out how to get anyone on the phone much less a technician to come and investigate my coax ports. Please can a real human being try and give me a hand? I'm very tired of listening to fake chat programs tell me to restart my modem and apologize for being unable to do anything.

 

The gateway that I am renting is the "TECHNICOLOR CGM4331COM" which should be rated up to 2.5gbs in it's high speed port, and 1gbs in all others.