Community Forum

Pods keep disconnecting

Jenniferrrr
Contributor

Pods keep disconnecting

Do the pods have a short lifespan? I've had mine (6 throughout the house) for a little over a year. Up until the last week, they worked seamlessly, and now, most of them are sporadically disconnecting, requiring a reset (unplug) daily. Nothing has changed, they're in the same locations as always. I've reset the router multiple times, I've "removed" pods and added them back, but all of these attempts result in temporary fix, and then within a few hours, the cycle starts all over again.
Given the cost of these, I would expect them to work successfully for more than one year, but wondering if anyone else has experienced this and what the solution is. I'd like XFinity to replace them, as they seem defective, but I don't anticipate Xfinity would accommodate that. 

bkprice13
New Poster

Re: Pods keep disconnecting

No one's replied yet? I have the same problem. Did your contract recently expire, by chance? Mine did, and the trouble with the (expensive) pods began at about that same time, and I got a very hard upsell on the need for faster internet, because apparently 100 is not fast enough for three people to be on a Zoom meeting at once (???). The guy also signed me up for a set of pods (when I'd already bought pods) and TV service without my knowledge. Makes me hesitant to contact their customer service again, for fear of what they'll add onto my account without my knowledge. They have a very poor track record of fixing anything.

Big_G10
Regular Visitor

Re: Pods keep disconnecting

Deleted my reply and opened a new post for a similar issue.