Community Forum

Pods always going offline

hoffmange138
New Poster

Pods always going offline

Why do Xfinity pods continue to go offline? I’ve had them plugged into the same outlets since I got them a year ago and just lately they have started to have major problems. It’s getting frustrating to the point I am about ready to make a switch!
KLE1
New Poster

Re: Pods always going offline

I'm having this same problem... it's constant all day.  Really disruptive to doing business at home. How do we fix this? 

Kayem13
New Poster

Re: Pods always going offline

I can’t answer the why but you’re not alone. This started happening to us recently. The chat online was useless. I did all the things they say to do multiple times and still they didn’t work. I restarted the system. I unplugged them all. I removed them from my system and tried to set it up as if from scratch. Nothing. I hunted around for a phone number to call and finally found 800-XFINITY. One simple suggestion worked: log out and log back into my Xfinity account on the app. Because I had unplugged them all I still had to reconnect them and it took time for sure but at least this time I actually was able to connect and activate the pods. Next time I will start by logging out and logging back in because that only took a minute and did the trick. They really should add that suggestion to their online troubleshooting list.
Jl922
New Poster

Re: Pods always going offline

This is very frustrating—like whack-a-mole. One shuts down, unplug and replay, and then 10 minutes later one or more shut down.

I knew I should have bought a mesh system from a third party.

The non tech help desk told me that the “advanced security” doesn’t play well with VPN, so I turned the advanced security off. No help.

What is the point of these things if they don’t work? And is Comcast trying to do anything about it? They did suggest having a technician come visit, for a few of course. How is it possible any of this is the result of anything but a hardware or software design flaw?
KarlMessner
New Poster

Re: Pods always going offline

I have three at home. One went offline once. Unplugged, replugged- fine. i have another building with three. TWO of them go off all the time. 

 

Biggest issue is I pay for 600 MBS download and currently get like 45 MBS 15 feet from base and my  office computer is connecting through the pod above me in the bedroom 😞