Community Forum

Paying for 200MBPS down, only getting 50 - 70MBPS down??

Highlighted
New Poster

Paying for 200MBPS down, only getting 50 - 70MBPS down??

I reached out to comcast a few days ago and had a tech install a new circuit to my house (first time this property is being connected to comcast). I spoke to the tech over the phone and he said that the issue has to be the modem. I have an arris sbg6580-2 Modem which supports up to 300 Mbps over wifi. I work for an IT company who uses comcast and we've used these modems before over hundreds of locations and we've never had this issue. I run multiple speed tests, used both 2.4 and 5.0 GHZ for my wifi and even while directly connect I'm still not pulling half the speed I pay for. What do I need to do to get help with this? I just paid for a tech to install a new circuit, I would've expected this job to be done right the first time...

Highlighted
Diamond Problem Solver

Re: Paying for 200MBPS down, only getting 50 - 70MBPS down??

Have you checked the specs at , it says Wi-Fi up to (key word) 99/102? Does the device you use to test have the capability to go over 100? Don’t complain about the job done until you go through all the troubleshooting steps too
https://www.xfinity.com/support/devices/#details

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
New Poster

Re: Paying for 200MBPS down, only getting 50 - 70MBPS down??

I feel foolish and I gotta apologize publicly now, though the device I use is capable of testing speed faster than 200mbps, I am getting it via ethernet, it's over wifi that I'm not getting it. pretty sure I ran the test yesterday while it was connected, but I must've not. Again, sorry comcast. #rip