Community Forum

Owned modem keeps "deactivating" and needs to be re-registered.

Highlighted
New Poster

Owned modem keeps "deactivating" and needs to be re-registered.


I've been trying to assist my father in switching from a leased modem to an older Xfinity gateway that I had (the Arris TG862G).

Initial set up took place about three weeks ago with zero problems. Everything worked great for about two days, then all internet features stopped working. Tv/cable was fine. I called customer support, and they seem confident that the only issue was they had to transfer the registration of this modem from my name, to my fathers name. They did this, and then I went through the process of re-activating the modem. Everything worked great for another two days, and then it all happened again.

This is been the pattern for the last three weeks. It stops working, so I drive over there and reactivate it, it works great for another couple days, and then stops again.

Tech-support is getting less and less helpful. Every time I call, they confirm the modem registration is correct and now in my father name, they do a roll and re-provision, and I confirm/re-enter with them the serial number, MAC number, etc into the xfinity system. It gets everything working again, but it's not solving the PROBLEM because this just keeps happening. The last customer service rep told me that the problem is 100% with the modem, and I should just go back to the leased one. I don't agree. I'm getting the impression it has something to do with the Xfinity system all of a sudden not recognizing/deactivating the modem. Can someone please help me figure out the ACTUAL CAUSE so I can find a solution?

Thank you all so much for any insight you could provide. I have spent hours and hours and hours on this, and multiple (3 hour) drives back-and-forth to my fathers house. So to say that I am beyond frustrated is an understatement.