Community Forum

Not receiving promised speed. My upstream speed at the take of the modem is an average of 7Mbps.

Highlighted
New Poster

Not receiving promised speed. My upstream speed at the take of the modem is an average of 7Mbps.

Hi,

 

Around mid 2018 we moved from AT&T to Comcast with great hope to get the fast internet service announced.

 

Since the begining the speed was slow but we were paying 39.99. 

 

As it is one of the offered options I decided to get a brand new and recommended modem Arris SB6190 from Costco.

 

The technician making the install could not make it work at max speed but he got lucky showing 17Mbps to my wife to which after hours she decided to accept. Afterwards the speed wend down. No solution  from Comcast despite my wife spent several hours on multiple days and occassions trying to get someone to help. However billing charges on the rise. We are now paying US$82+ monthly.

Now we received am email saying that the speed has been increased to 200Mbps, no need to do anything as it is included in my plan. 

 

When we measure the speed we have a computer directly conneced to the modem port. No other devices in the middle.

Measuring the speed of the connection at the port of the modem the average speed we are getting is 7+ Mbps.

Ocassionally also, the service goes down. The black out can last the entire night and the the service comes back by itself.

 

I am writing this message,  signing in with my username/password provided by Comcast and associated to my contract in a desperate effort to get some sort of help. We are positive that  reaching the right people this have a chance to work. We are not really in the mood to chage back to AT&T we are finally convinced that there is no solution. 

 

Does anyone know of anything like this and the way it got solved?

 

Thanks in advance for any response.

 

Thanks