Community Forum

No devices are able to connect to my Home XfinityWifi SSID

Highlighted
Frequent Visitor

No devices are able to connect to my Home XfinityWifi SSID

I have exhausted my efforts in searching for resolution on the general internet, Reddit, the Xfinity forums and wifi.xfinity.com faq's. Last week I re-enabled the XfinityWifi Guest WiFi on my CGM4140COM as depicted in the screenshot above. Now, regardless of device type (Windows 10, Android, iPhone) me or any of the family/guests who are staying with me are unable to connect to this xfinitywifi or xfinity hotspot with excellent signal. As an example, in the above screenshot, when we attempt to connect to xfinitywifi it just says connecting for about 15 seconds and then goes back to Open. It never connects to the network. On my Android, when I try to connect it sits on Obtaining IP address and then hops back to saved and back and forth until I choose to Forget The Network. It does this with multiple computers and phones. It simply is refusing connection from anyone.

I have reset the router and I have used Chat Support, to no avail. Surely this must be a known issue that occurs from time to time, but I can not for the life of me remedy the situation.

When my hotspot is disabled there is a very poor xfinitywifi signal from down the street that barely registers for any of my devices here in the house, and I am just wondering if its some sort of SSID collision or something?


Thanks in advance!

Highlighted
Diamond Problem Solver

Re: No devices are able to connect to my Home XfinityWifi SSID

Did you try swapping out your gateway?

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
Frequent Visitor

Re: No devices are able to connect to my Home XfinityWifi SSID

Like, have Comcast send me an entirely new Gateway? No... I would think that would be like throwing out the baby with the bathwater, but I am open to that if that solves the issue. Was hoping this would be a setting either in the firmware that Comcast would be able to assist with or something server side.

Someone on reddit said this recently which kind of surprises me but I wonder if it could be the case?

"There is a blacklist.

Any MAC address that has connected to your private wifi gets denied connecting to the public wifi radio off of the same gateway. This is account wide so it won’t reset by swapping the gateway.

There used to be a checkbox in the GUI wifi settings somewhere that said “prefer private connection” or something along those lines. Unchecking it would bypass the blacklist.

With all the offloading from GUI to cloud functionality for XFi...I’m not sure if this option is available anymore."

Highlighted
Frequent Visitor

Re: No devices are able to connect to my Home XfinityWifi SSID

I solved this issue by navigating to http://10.0.0.1/connected_devices_computers.php and unchecking the box that stated "Prefer Private Connection"

 

Once I did that, all my devices are now connecting to xfinity and allowing me to authenticate on the web front end.