Community Forum

New Router/Modem, two of my devices can't connect (others can)

Highlighted
New Poster

New Router/Modem, two of my devices can't connect (others can)

I recently bought the 1 gig tier speed and for that they had to replace my modem/router. I got it a day or two later, and I set it up, everything in the house was working except for our two MSI Laptops. They worked with the previous router perfectly (rental that did 300 Mbs) and today they can't see the network. I've tried countless reboots on both device sides and nothing. I see all the other networks in the area, I can connect to the comcast xifinity wifi no issues, but I cannot connect to the new network that was set up. We also have a dell laptop and it had no issues with the new network.

 

I've tried calling support, but they just keep going in a endless loop of trying to reset our router and not getting a REAL human to talk to. Chat is also equally worthless. 

 

Also I can't really tell the difference in speed. I probably will cancel this service and go back to the privious tier since it worked flawlessly, I just wanted more speed, but I guess I can't have everything I want.

Highlighted
New Poster

Re: New Router/Modem, two of my devices can't connect (others can)

Kinda "fixed" my issue, turns out the new router supports Wifi 6 (ax), and the old one supports Wifi 5 (ac). So we bought a netgear wifi that supports AC mode, and hooked it up to the Comcast router, and the laptops are back on the network.

 

I still see HORRIBLE speeds.