Community Forum

New MB7621 Modem + Orbi Mesh - cannot get to work

Highlighted
New Poster

New MB7621 Modem + Orbi Mesh - cannot get to work

Finally had it with my Netgear C300 which is giving me wireless speeds of 25-50MBS on a 300MBS plan (wired gets over 200MBS)...

 

First had Comcast technician out...replaced the line from the pole to the house...confirmed the splitter (one line to modem, one to tv) was good...and they found a "node issue" in the neighborhood that was fixed the next day.  This helped my wired speed be more consistent, but didn't do much for wireless.  Another phone tech said my modem details were not registered with Comcast, so I gave them the MAC/SN/TA.  Not sure anything really changed - maybe the wireless speed is more consistent in the 20+ range (there were many times it would be <5MBS!).

 

Anyway, new MB7621 (Motorola) modem works ok wired - close to 300MBS - BUT first sign of an issue is that the browser locks up for several minutes after the speed test.

Moved on to trying to connect the Orbi mesh router...and after pairing with the satellite (which oddly takes multiple attempts with the satellite 10 feet away) - there is no Internet connection.  Did this multiple times - resetting modem each time, etc.

 

Decided to pay for two internet connections temporarily so I can work with the new modem without having to keep registering old/new back and forth (I need the wifi for work, so when I can't get it working, I have to go back to the Netgear, re-activate, etc.).

 

Had hoped these two devices would just be plug-n-play - but clearly I am doing something wrong (or there is something wrong somewhere and I can't figure it out).

 

Appreciate any help.  Thx

Highlighted
Diamond Problem Solver

Re: New MB7621 Modem + Orbi Mesh - cannot get to work

Since you’ve stated your internet connection to your modem is good, shouldn’t you be working with Orbi? None of the equipment is Comcast’s to troubleshoot.

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
New Poster

Re: New MB7621 Modem + Orbi Mesh - cannot get to work

Yes...and I am checking wih Netgear and Mororola as well.  Just thought perhaps CC would know of a setting or something else in the configuration.  Seeing that after several service calls, no agent ever mentioned that my modem details were not in the system....and after an agent said he had added them yesterday, and a second agent asked me for them again (meaning the first agent didn't add them as he said he did) - I don't exactly have the highest confidence in CC at the moment.

Highlighted
Diamond Problem Solver

Re: New MB7621 Modem + Orbi Mesh - cannot get to work

Just thought perhaps CC would know of a setting or something else in the configuration
___________
They aren’t going to troubleshoot equipment that isn’t theirs. Same as if you asked for a tech to come out.

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!