Community Forum

Network not showing up at all on laptop *SOLVED*

AMills01
New Poster

Network not showing up at all on laptop *SOLVED*

We just upgraded to the gigabit speed internet, which required us to trade in our old xfinity modem for a new one. Since we changed modems, everything in the house finds and connects to the wifi, except for my laptop, which can't see our network at all. It sees all my neighbors networks but ours just doesn't show up on the list. I can use my phone as a hotspot and connect my laptop to the internet that way just fine, so there's nothing wrong with the wireless card and since I could connect to the old modem it's obviously something to do with the new one. I've tried deleting the remembered wifi network and manually re-entering it, I've restarted the modem and my laptop umpteen times, but still nothing. Customer service has no clue. Can anyone help me?!

 

ETA: It turns out I just needed to update my wireless card drivers, hope this helps anyone else with the same problem! 

EG
Expert

Re: Network not showing up at all on laptop

The two WiFi bands have recently been combined into one with the Comcast gateway devices. Some devices get confused and don't know how to see / talk to combined bands.


If you are not using any Xfi Pods, you can try separating the 2.4 and the 5.0 bands and give them two different broadcast names / SSID's;


https://www.xfinity.com/support/articles/change-wifi-mode-admin-tool-xfinity-xfi





I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
AMills01
New Poster

Re: Network not showing up at all on laptop

It turned out I just needed to update my wireless card drivers. Thanks for your reply!