Community Forum

Netgear C7800 Modem/Router Issue: Upstream/Downstream Lights blinking

Highlighted
New Poster

Netgear C7800 Modem/Router Issue: Upstream/Downstream Lights blinking

Hi there, 

Yesterday everything was working fine. Today my internet went out. After a very long time on the phone with comcast, they said everything was fine on their end (of course). So I contacted netgear (same story). A little digging around and I believe the current firmware actually causes my Modem/Router to have a bug and it is stuck in an endless "firmware upgrade" cycle. 

 

Does anyone know of any fixes? I found a video where the guy had the same problem on a different product and the way to fix it was to download the lastest firmware and try to manually reset everything. 

 

However with the Netgear C7800 all firmware is pushed by Comcast (my ISP) and I am unable to download the firmware. 

 

EDIT 1: I have tried every combination of reset possible. 1. Reset by unplugging the netgear. 2. comcast reset as is presented in the app. 3. factory reset as instructed by Netgear 4. all combinations of cable in/ cable not in. 

 

This is really frustrating and I hope someone can help me out. 

 

On my Modem/Router here are the status lights:

 

Power: Constant On

Upstream: Slow Blinking

Downstream: Slow Blinking in sync with the upstream light. 

Internet: Constant On but no connectivity

 

Please Help, I've lost an entire day of work and would not like to lose another. 

Highlighted
Expert

Re: Netgear C7800 Modem/Router Issue: Upstream/Downstream Lights blinking

What do the modem's signal stats look like ? Try getting them here; http://192.168.100.1

Please post the *Downstream Power Level*, the *Upstream Power Level*, and the *SNR* (Signal to Noise Ratio) numbers.

?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: Netgear C7800 Modem/Router Issue: Upstream/Downstream Lights blinking

I will post tomorrow. Thank you for your help
Highlighted
New Poster

Re: Netgear C7800 Modem/Router Issue: Upstream/Downstream Lights blinking

Hi there: as requested

Downstream:
Channel 1 is the only locked channel
Power: 5.2 dBmv
SNR: 43.1 dB

Upstream:
No locked channels
Power level: 36.0 dBmv

I know I didn’t list the SNR. That’s because one is not listed. When I attempted to refresh the page it just went right back into the endless firmware Upgrade.

The exact message looks like a black screen with two green parallel bars and the message:

“Firmware is upgrading, please don’t power off and wait upgrading to be completed...”

And this was on all night in hopes that this morning would be different no change though.

Highlighted
Expert

Re: Netgear C7800 Modem/Router Issue: Upstream/Downstream Lights blinking

Please copy and paste the text or post a pic of all of the upstream and downstream channels.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!