Community Forum

Microsoft Remote Desktop

Highlighted
Regular Visitor

Microsoft Remote Desktop

Switched to Xfinity 2 weeks ago. Got an emergency request to Remote Desktop into a server and kaboom, blocked by Xfinity. What is the solution? I tried opening port 3389 put still can't get through.  Did not have this issue with Uverse and neither did I have to open a port.  Very irritating.

Highlighted
Regular Visitor

Re: Microsoft Remote Desktop

I also can't get to my office remote desktop server using my Xfiniti Network. I am able to get in using my cell service. What setting needs to be changed to allow a Remote Desktop client to connect through the Upgraded modem/router that I have recently installed?

Highlighted
Regular Visitor

Re: Microsoft Remote Desktop

Check my posting from 4/14. You have to turn off the “advanced security “ setting using the XFi app or web portal and it will work then. Defeats the purpose of the security settings. Just remember to re-enable it when you are done.
Highlighted
Regular Visitor

Re: Microsoft Remote Desktop

No luck. Pretty frustrating. I have reset my xfiniti modem/router to factory, disabled the "Advanced" security, turned the ipv4 and 6 firewalls off, disconnected all other devices. I am able to use remote desktop to my windows 2016 server when I use USB internet connection sharing with my phone, but in spite of all of the above I cannot get to the RDP server in my office through my Xfiniti internet connection. Xfiniti support is no help.... I may just end up using my ATT wireless service to connect to work....

 

TC8305C Firmware Update, Can't Remote Desktop Anyone else out there having this problem?

Highlighted
New Poster

Re: Microsoft Remote Desktop

I would consider setting up a VPN and connecting first through the VPN then using your RDP client.  Also I would port forward 3389 its a common attack vector. 

Highlighted
Regular Visitor

Re: Microsoft Remote Desktop

Thanks, I think that is good advice. It started working again spontaneously? I looked at the log on the server and found that I was under a brute force attack, 221,000 login attempts in the last 24 hours.  None got in....

I have turned the RDP server off for the weekend. I will check into the VPN option. Just another time consuming thing to set up for everyone, but probably worth it.