Community Forum

Internet speeds have declined horribly

Highlighted
New Poster

Internet speeds have declined horribly

I have 75 mb internet with Blast.  I normally can get speed tests to average around the 225mb download whether I'm on wired or wireless.  I do own my own modem, and I also have my own WiFi router.  Two days ago I noticed internet was slow, and did a Speedtest.....awful slow....10-15 mb....I did several tests throughout the day, but was busy with other things.  Later Saturday evening it seemed as the situation had corrected itself as speed tests were back to normal.  Two hours later, my daughter says internet acting up again, and yes, speedtests back to minimum again.  I resolved that I must have a modem goin bad, because even if I took the WiFi router out of the equation and connected my top directly to the modem, my speeds were full extremely slow.  I ordered a new modem to pick up at BestBuy Sunday morning.  Picked it up, took it home and installled it.  Did the self activation and everything seemed back to normal speeds for a few hours.  Left home for few hours come back last night to find download speeds back to 20-25 mb.  I've chatted with Comcast to nooooooo avail.

I finally talked to a customer service rep who tested with me and said yes, there seems to be some issues, and then tells me it will be Wednesday before someone calls me to do more tests???  I've checked all my coaxial connections inside the house and like I said, I've even bought a new modem and the issue isn't resolved.  Why must I wait three days before someone calls me to do more troubleshooting?