Community Forum

Im only getting 30mbps of internet out of my 300mbps

PabloB21
New Poster

Im only getting 30mbps of internet out of my 300mbps

I got my service connected yesterday and the speed has not improved what so ever. I disconnected every device and ran various speed tests standing literally in front of the router and I haven’t found any improvement. Im paying for 300mbps and i’m not getting even half of the speed and its quite unpleasant due to the fact that I always have about 7 devices connected at all times.
EG
Expert

Re: Im only getting 30mbps of internet out of my 300mbps

Is this with a WiFi connection ? If so, for a test, does a computer hardwired directly to the router / gateway device with an ethernet cable have the same problem ?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
PabloB21
New Poster

Re: Im only getting 30mbps of internet out of my 300mbps

Yes it’s overall horrible
PabloB21
New Poster

Re: Im only getting 30mbps of internet out of my 300mbps

still the same, horrible
EG
Expert

Re: Im only getting 30mbps of internet out of my 300mbps

What do the modem's signal stats look like ? Try getting them here http://192.168.100.1 or here http://10.0.0.1

Please post the *Downstream Power Level*, the *Upstream Power Level*, and the *SNR* (Signal to Noise Ratio) numbers.

What is the exact make and model number of the modem ?




I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!