Community Forum

Horrible service

Highlighted
New Poster

Horrible service

I've had this service for 4 days and have had to call twice and have had 3 problems (well 4 really, one problem happened twice)
1st. Took almost an hour for the service to finally connect first time.
2nd. Web site and app would not load, kept telling me "there is an issue with your account"
3rd. Twice now it was working fine at night then the next morning nothing. First time it happened took about an hour of resetting it to finally come on. Second time have to have a tech come out.
I switched to cable internet cause it was supposed to be reliable.
Highlighted
Official Employee

Re: Horrible service

Hi Danielchurch63. Thank you for visiting and posting on our Forum. Apologies for our delay in getting to your post. We're very sorry to learn that your service has not been performing the way you have come to expect. We're dedicated to repairing and restoring your service. I can assist with troubleshooting your service issues. Please reach out to me via private message and include your full name so I can assist you. To send me a private, message click my name (ComcastJoeTru) to view my profile. Then click "Send a message" and private message me. 




I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!