Community Forum

High Latency Issues

Highlighted
Regular Visitor

High Latency Issues

Hello,

 

I am experiencing very high latency issues and it's making online gaming and other services very difficult to use. My speeds are overall fine, but the response times are unbearable. Here are some ping statistics:

 

Pinging comcast.net [69.252.80.75] with 32 bytes of data
Reply from 69.252.80.75 bytes=32 time=102ms TTL=47
Reply from 69.252.80.75 bytes=32 time=142ms TTL=47
Reply from 69.252.80.75 bytes=32 time=318ms TTL=47
Reply from 69.252.80.75 bytes=32 time=99ms TTL=47
Reply from 69.252.80.75 bytes=32 time=105ms TTL=47
Reply from 69.252.80.75 bytes=32 time=260ms TTL=47
Reply from 69.252.80.75 bytes=32 time=239ms TTL=47
Reply from 69.252.80.75 bytes=32 time=71ms TTL=47
Reply from 69.252.80.75 bytes=32 time=103ms TTL=47
Reply from 69.252.80.75 bytes=32 time=79ms TTL=47
Reply from 69.252.80.75 bytes=32 time=170ms TTL=47
Reply from 69.252.80.75 bytes=32 time=126ms TTL=47
Reply from 69.252.80.75 bytes=32 time=134ms TTL=47
Reply from 69.252.80.75 bytes=32 time=176ms TTL=47
Reply from 69.252.80.75 bytes=32 time=176ms TTL=47
Reply from 69.252.80.75 bytes=32 time=314ms TTL=47

 

As you can see, almost all response times are over 100ms, and this is on a wired connection directly to the modem (ARRIS TG3482G). This happens throughout the day, and I have recently replaced the modem, cabling, and have completed all steps in this document: https://forums.xfinity.com/t5/Your-Home-Network/Internet-Troubleshooting-Tips/m-p/3310447#M316652.

 

What can I do to fix this issue? Do I need another new modem? Or a faster speeds? Here are my modem signals as well. Any help is appreciated.

 

Modem Signals.PNG

Highlighted
New Poster

Re: High Latency Issues

I am having the exact same problem. I talk with customer support: "We only help troubleshoot issues with internet speed, not latency".

Absolutely ridiculous. Many of my favorite games are unplayable under these conditions.

I can tell you right now the problem isn't your speeds, or your modem. I pay for gigabit speeds (and I still get them just fine), but my latency has been inconsistent for weeks. Multiple people in my building have reported the same issue who are on Xfinity. WaveG apparently doesn't have this issue in our area, so I'm switching once the month ends.