Community Forum

Help, Comcast will not come out to fix faulting line because of COVID?

Highlighted
Contributor

Help, Comcast will not come out to fix faulting line because of COVID?

I have Comcast Internet and TV and often have connectivity issues.

 

According to the technicians, squirrels or other animals chew on the cables and my connection becomes unstable every few months.

 

Once again, my connection is dropping 20+ times a day, but comcast is refusing to come and fix the line.

 

I work from home these days a need a reliable Internet connection which it is anything but.

 

I have been trying for weeks now with appointments. They say they can only go outside, which is fine with me as the issue is always with the outside cables, but every time they cancel and say they will come another day, but they never do. Each time they give a different excuse and often blame COVID.

 

I still have a few months left in my 1 year agreement, but cannot go an hour without a drop. What can I do do fix it or if needed cancel and go somewhere else?

Highlighted
Contributor

Re: Help, Comcast will not come out to fix faulting line because of COVID?

I signed up for Uverse Internet which is slower and more expensive than Comcast, but will hopefully work. But when I called Comcast to set up a cancellation they wanted one more chance to fix it so they are once again claiming to send a technician to fix the problem. Will see what happens.

Highlighted
Contributor

Re: Help, Comcast will not come out to fix faulting line because of COVID?

A technisioan did finally come by. They did not say what they did, just that they fixed the problem and are now monitoring. At least for the past couple days it seems to be working fine.

 

ATT did get installed so for the moment I have both. If Comcast holds I will keep it, if not I have to try ATT for now.

Highlighted
Contributor

Re: Help, Comcast will not come out to fix faulting line because of COVID?

So I had no issues for a couple days so I canceled ATT. Then once again Comcast started having constant disconnects.

After another couple hours with support, they again did something and once again fixed the problem and it is working again. They did not tell me what was the problem, but once again it seems to be stable.