Community Forum

HP Printer not working since Xfi install

Highlighted
New Poster

HP Printer not working since Xfi install

Hi,

 

Just switched from Uverse to Xfi gig . Seems a good service , well apart from getting 950 mbps with ethernet , but onlu 90 mbps wifi from 12 inches away , testing with 5 different devices ...

 

Anyway, since the install last week, my HP printer is not working. I have tried with 4 laptops and the same issue. None of them are seeing it. I have tried powering it down, clearing netwrok and redoing the setup wizard. It is on the same netwrok name and connecting OK.

 

I have tied using the HP APP on PC - it says offline and cannot fix

I downloaded the HP print doctor app and that did not work.

I tried using my brand new laptop to 'connect new printer' and it is not discovering it on the network. 

 

I have disabled advanced security (did this anyway for my Plex server remote access) 

 

Any ideas ?

 

thx 

Highlighted
Frequent Visitor

Re: HP Printer not working since Xfi install

I had same with epson printer,would not connect wifi.tried everything to fix.called epson and called comcast 3 times. noone knows,so I went back to old router XBT6.work ok now.still cannot get advertised speed.they cant seem to help with that either,I have about 300 mbps on ethernet cable and 200mbps on wifi,usable but not the 500mbps they said

Highlighted
New Poster

Re: HP Printer not working since Xfi install

After telling the agenct on Xfinity chat my PRINTER issue - they proceeded to reset router and then tell me my INTERNET should now be working. Seriously ??!! lol 

 

I just got this messge: As per checking it here that since your modem is GREEN and you are able to access Internet in your devices, I would recommend for you to contact our Advance Wireless Team @1-800-934-6489 to help you set this up and address this concerns right away.

Highlighted
Diamond Problem Solver

Re: HP Printer not working since Xfi install

Unless you have pods, have you tried separating your wireless networks?

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
Contributor

Re: HP Printer not working since Xfi install

Had same issue - older HP printer did not like mesh of XB7.  It did work for a while when it conected to a pod 2 rooms away at 2.4G.  Can you put a pod close to it, and connect via ethernet.  Bet that would work and how I have had to connect some devices that do not like mesh or have no wifi.

 

I bought a new HP laserjet.....  fixed the issue

Highlighted
Frequent Visitor

Re: HP Printer not working since Xfi install

Yes I thought of that buying a new printer don't want to spend Bear 400 right now on that. I think the newer printers probably would work fine. Mine is at least 10 years old
Highlighted
New Poster

Re: HP Printer not working since Xfi install

I have it working for my wife with direct setup via USB. However, that does not solve for the other 6 laptops via wifi.

 

Is this something I should even waste my breath talking to Xfinity about ? It is tedious wasting time talking to people who have no clue. 

 

thx 

Highlighted
Contributor

Re: HP Printer not working since Xfi install

Does it have a ethernet port?  If so you could conect to a pod, or the cablemodem.  otherwise, wasting time IMO.  No, prob not an Xfinity issue.

Highlighted
New Poster

Re: HP Printer not working since Xfi install

Hi, what does that mean ? Thx
Highlighted
Diamond Problem Solver

Re: HP Printer not working since Xfi install

Again, have you tried separating your wireless networks?

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Highlighted
Contributor

Re: HP Printer not working since Xfi install

CC - have you ever worked with mesh networks?