Community Forum

[HELP] Unable to Connect to Battlenet, Twitch, Discord, Etc.

New Poster

[HELP] Unable to Connect to Battlenet, Twitch, Discord, Etc.

Hi all,

 

Just switched modems to the Arris TG1682G and 150 MB/s plan with Xfinity and am now all of sudden unable to connect to get certain applications to connect to their host services. As examples, Battle.net can't connect to blizzard, Discord can't connect and never gets past "looking for updates", Twitch desktop app DC's within seconds of startup, etc. I am hardwired into the modem from my desktop. 

 

I've found the following forum link: https://forums.xfinity.com/t5/Your-Home-Network/Connectivity-Issue-with-Game-Servers/m-p/2123790#M43...

which seems to address my exact issue however I'm not going to pretend that I understand how to actually implement the solution. Would appreciate any help as this is extremely frustrating...paying a ton for internet that I can't effectively use. If you understand the solution provided in the link, could you please explain it to me like I'm 5 years old...happy to provide any info required to do so. 

 

I've already done the following to try and troubleshoot: uninstalled Norton, temporarly disabled windows firewall, extended power cycles, flushed DNS. 

 

Thank you all. 

New Poster

Re: [HELP] Unable to Connect to Battlenet, Twitch, Discord, Etc.

EDIT: I've managed to find my way into the LAN settings of my modem and have changed the DHCP IP range...(even a blind squirrel finds a nut). Now it's telling me the reserved IP i'm trying to configure is outside the range I've set...but the whole point is to set a unique ID for my desktop PC, no?

Expert

Re: [HELP] Unable to Connect to Battlenet, Twitch, Discord, Etc.

https://www.xfinity.com/support/articles/port-forwarding-xfinity-wireless-gateway



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: [HELP] Unable to Connect to Battlenet, Twitch, Discord, Etc.

Hey there EG. Appreciate the quick reply. So I've gone through the article and have set up presets for port forwarding but am now presented with the following issue: 

 

(Please note I've already associated my desktop PC with the HOME network, have selected it during the drop down menu when creating port forwards, and am using Xfinity presets for League of Legends / World of Warcraft). 

 

For the preset port forwards, it's set the reserve address to 10.0.0.xx however my PC under the default admin gateway is still DHCP. I've tried to switch my desktop from DHCP to reserved IP through the gateway website but it refuses to change from DHCP. Also, and not sure if it matters, when I look at the Port Forwarding page it still says "NO ASSOCIATED DEVICE" even though i selected my PC from the dropdown menu when setting up said port forwards.