Community Forum

FIX: Device doesn't show in port forwarding list

New Poster

FIX: Device doesn't show in port forwarding list

Worked with xFinity for hours today trying to fix this.


Can only add devices listed in xFi console, unlike before you could do in the router config easily.


In this case I was trying to set a manual IP device to forward, but it just wouldn't show on the list in Port Forwarding option in xFi.



Turn off ipv6 on your destination device

Unplug device from network

Forget the device once it shows disconnected in xFi console.

In router console, create a manual IP reservation mapping using an address 2-252 (10.0.0.x in most cases), and add the MAC address of the device, and give it a name you will remember.

Set the same manual IP setting on your device.

Plug in device to network.

Wait for it to show online in router console.

Switch the device to DHCP in the router console.

After a few minutes the device will now show in the Add Port Forward drop down.

It appears even though you now set DHCP, that the IP address will stick because of the MAC address set.


Paul Field