Community Forum

Extreme Pro Internet - No Change From Previous Speed

Highlighted
Contributor

Extreme Pro Internet - No Change From Previous Speed

Two weeks ago I changed my internet from 175 mbps to extreme pro at 600 mbps. Before the change I was achieving 160 - 180 mbps download speeds as measured by the xfinity speed test app. After recycling my modem and router I experienced no change in the download speed. II called customer service to see if my plan was actually changed. The service person said he did change and I was on the 600 mbps plan but he needed to check something and instead of me waiting on hold he would call me back. He never called and I still do not have an answer to my question as to why I see no change from my prior speed. I checked the specs on my modem (SB6190) and wireless router (Netgear R6300 V2) and both are capable of achieving 600 mbps. My computer adapter also is capable of this speed. Has anyone experience this issue or can offer advice?

Highlighted
Expert

Re: Extreme Pro Internet - No Change From Previous Speed

For a test, what speeds do you get with a computer connected directly to the 6190 (no router in the mix) ?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Contributor

Re: Extreme Pro Internet - No Change From Previous Speed

Thanks for the reply. Connected directly to the 6190 I get 638. When I bring the router into play I get 360 when connected to a LAN port and 180 connected by wifi.  I guess Comcast is delivering the speed to the modem but the bottleneck is the router. When I check the router specs it appears to handle high speeds (Ethernet 10Base-T/100Base-TX/1000Base-T) and wirelessly (Fast 802.11 AC Router- AC1200 (300+867Mbps)  so I am confused as to why I have such low throughput out of the router. At least I know the router is the problem. Now to decide which router to buy.

Highlighted
Expert

Re: Extreme Pro Internet - No Change From Previous Speed

Are there any QoS settings enabled in that router ? If so, try disabling them. 

 

FWIW, I had that router in the past and I ditched it after a month because of the same problem. I could never get good throughput performance with it. Good luck !



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Contributor

Re: Extreme Pro Internet - No Change From Previous Speed

Thanks EG. Whch router did you end up with?

Highlighted
Expert

Re: Extreme Pro Internet - No Change From Previous Speed

There have been many ! I'm currently using Netgear X4S R7800.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!