Community Forum

Ethernet Works But WiFi Does Not

smsil2
New Poster

Ethernet Works But WiFi Does Not

Our internet works when connected via ethernet. We can also see our WiFi signal has full-strength, but once connected to WiFi, our devices all say there is no internet. 

jav6joev
Bronze Problem Solver

Re: Ethernet Works But WiFi Does Not


@smsil2 wrote:

Our internet works when connected via ethernet. We can also see our WiFi signal has full-strength, but once connected to WiFi, our devices all say there is no internet. 


Sounds like your devices may be getting an IP address from your gateway/router (providing the WiFi signal) but are not getting a gateway or DNS server address assigned allowing it to get out to the internet.  There may be a setting in your gateway/router that needs adjusting.  What gateway/router make/model do you have?

Joe V
(not a Comcast employee, just another paying customer)
EG
Expert

Re: Ethernet Works But WiFi Does Not


@jav6joev wrote:


Sounds like your devices may be getting an IP address from your gateway/router (providing the WiFi signal) but are not getting a gateway or DNS server address assigned allowing it to get out to the internet.  


Hmmmm.... They stated this: "Our internet works when connected via ethernet."



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
jav6joev
Bronze Problem Solver

Re: Ethernet Works But WiFi Does Not


@smsil2 wrote:

Our internet works when connected via ethernet. We can also see our WiFi signal has full-strength, but once connected to WiFi, our devices all say there is no internet. 


Is your gateway/router's internet connection set for Automatic DHCP, Manual or Bridge Mode?  

Joe V
(not a Comcast employee, just another paying customer)