Community Forum

Double NAT in bridge mode

Highlighted
New Poster

Double NAT in bridge mode

I have a Google Nest wifi system, with its own router.

 

To avoid double NAT, I put my modem (xFi advanced gateway) into bridge mode.

 

However, it is still broadcasting/assigning an IP (10.0.0.221 to be precise), and so my Nest system is using the wrong WAN IP and so remains subject to double NAT. My understanding was that putting the modem in bridge mode would avoid this problem.

 

What can I do to be sure that my modem in bridge mode doesn't continue to assign an inappropriate IP?

 

 

Highlighted
Expert

Re: Double NAT in bridge mode

That IP address shows that it's not really in "bridge mode".  See this;

 

https://www.xfinity.com/support/articles/wireless-gateway-enable-disable-bridge-mode



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!