Community Forum

Devices will not reconnect to wifi

Highlighted
New Poster

Devices will not reconnect to wifi

I have a number of smart devices that have been connected to my wifi network for over a year with no problems. I have a Fitbit scale, a Google home mini, and a few smart plugs from different manufacturers.

 

Yesterday morning, all of them disconnected from my wifi at about the same time. My computers and phone never disconnected. I've tried factory-restarting all of the devices, and while they can find my wifi network in their respective setup apps, they cannot connect it it. I've tried telling the xFi app to forget the devices, thinking that might clear some bad cached data, but no dice. 

 

I've contacted Comcast twice today. The first time, the rep ran a remote diagnostic and said there was something wrong with some file on my modem. He updated it and stated flat out that what he did would fix the issue with no other actions on my part within 45 minutes. (I questioned that; I've worked in tech support and know you never guarantee a fix, but he was insistent.) Sure enough, an hour later I was still seeing the issue, so I contacted support again. This time, they told me that there's nothing wrong on their end and it must be a problem with my devices.

 

Which is more likely? That four devices from four separate manufacturers suddenly stopped working at the exact same time, or that there's something wrong with the wifi?

 

Since I'm not getting any help from support, does anyone out there have any ideas?