Community Forum

Desktop wifi is being automatically put on 2.4ghz instead of 5 ghz. I can't choose which I want.

Highlighted
New Poster

Desktop wifi is being automatically put on 2.4ghz instead of 5 ghz. I can't choose which I want.

I have gigabit internet through comcast xfinity, but am only getting ~90mbps through wifi and hardline. A tech came out and checked the modem, which was recieveing the proper amount, and my cable turned out to be an old cat5 which won't go higher than 100mbps. I ordered a new cable, but in the meantime was trying to use my wifi.

 

This is for my desktop, which has a newer wifi card (the ArcherT9E). It's supposed to support "1300Mbps on 5GHz band or 600Mpbs on 2.4GHz band" but I'm only getting ~90mbps through it as well. 

 

The tech showed me that I was connected via the 2.4ghz and said that the modem decides automatically which network a device is placed on. She said I'd have to change my network settings to connect my pc through the 5ghz, but when I go to 10.0.0.1 it won't let me change anything.  I get this message "

Wi-Fi Mode, Security Mode, Channel Selection, Channel Mode, and Channel Bandwidth are being managed automatically to help optimize your home Wi-Fi network and improve Wi-Fi coverage. To edit your Wi-Fi Network Name & Network password, please download the Xfinity xFi app or visit xfinity.com/myxfi."

 

I tried changing my settings on xfinity.com, but currently I've got a loading wheel saying "changing wifi settings" but it hasn't done anything and it's stuck. I've reloaded the page and tried a few times, and it always hangs up here.

 

 

My main goal is to have both 2.4ghz and 5ghz show up as networks i can choose, or if I can't do that, then I want the modem to select the 5ghz network for my desktop. Any help would be greatly apprecated.

 

Thanks

Highlighted
New Poster

Re: Desktop wifi is being automatically put on 2.4ghz instead of 5 ghz. I can't choose which I want.

Quick update - I was able to change the wifi settings, and have both the 2.4 and 5 ghz networks show up by changing the settings through the xfi app. I wasn't able to change any settings elsewhere, even on 10.0.0.1

 

Desktop is getting about 500mbps now,  which is a vast improvement.