Community Forum

Connectivity to sites in China: takes minutes, disconnects, stalls

gbBerkeley
New Poster

Connectivity to sites in China: takes minutes, disconnects, stalls

Does the Great Firewall of China have something against connections coming from Comcast.   A couple of times a month when I try to connect to sites based in China (hosted by Alibaba Cloud) the connections take 5-10 minutes, stall, never complete, disconnect, etc.

 

My colleagues who use other internet providers do not see any of these problems.

 

What gives?

 

jav6joev
Bronze Problem Solver

Re: Connectivity to sites in China: takes minutes, disconnects, stalls


@gbBerkeley wrote:

Does the Great Firewall of China have something against connections coming from Comcast.   A couple of times a month when I try to connect to sites based in China (hosted by Alibaba Cloud) the connections take 5-10 minutes, stall, never complete, disconnect, etc.

 

My colleagues who use other internet providers do not see any of these problems.

 

What gives?

 


Have you tried traceroutes and/or pings to see where the delay is?

Joe V
(not a Comcast employee, just another paying customer)
EG
Expert

Re: Connectivity to sites in China: takes minutes, disconnects, stalls

5 to 10 minutes is way more than a "delay" for the traceroute tool to be helpful........ Something else is going on that isn't RTT......



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!