Community Forum

Comcast Xfinity speeds work fine on all devices except my Iphone. Why is that?

Frequent Visitor

Comcast Xfinity speeds work fine on all devices except my Iphone. Why is that?

I just got Comcast Xfinity internet after moving with a 60 Mbps plan. I have 2 laptops that are getting fairly close to 60 Mbps (Download Speed seems to range from 30-60 Mbps whenever I test them). My Iphone on the other hand is literally getting 1-2 Mbps. It's so slow that I can't even watch Youtube or listen to Spotify without it buffering every couple seconds.

 

Why is this happening? I have never had this problem before with any of the previous Internet providers that I've had. Why is it just my Iphone that is experiencing really slow speeds on my Comcast connection (it works perfectly fine when I use it on other Wifi connections, so I know it's not my Iphone).

Contributor

Re: Comcast Xfinity speeds work fine on all devices except my Iphone. Why is that?

Are you using the 5g band on your wifi for your iphone? Its alot faster then the 2.4g band, just a thought

Frequent Visitor

Re: Comcast Xfinity speeds work fine on all devices except my Iphone. Why is that?

@jlavaseur How do I switch it to the 5g band?

Contributor

Re: Comcast Xfinity speeds work fine on all devices except my Iphone. Why is that?

Go to settings on your iPhone, under wifi, tap that and a list of available access points will show up, pick what you named your 5g wifi band to connect to it.

Frequent Visitor

Re: Comcast Xfinity speeds work fine on all devices except my Iphone. Why is that?

@jlavaseur I tried that and apparently my Wi-Fi Router only has 2.4ghz as an option. It's a Linksys E1200 N300 Wireless-N Router, which I just confirmed using a simple Google Search that it's only capable of using Wi-Fi in the 2.4ghz range.

 

Any other suggestions? Is my only option to simply buy another router that has 5ghz?

Contributor

Re: Comcast Xfinity speeds work fine on all devices except my Iphone. Why is that?

Since you only have the 2.4g wifi band and your other devices are working ok, i think its something else, i read where your router is good for 300 Mbs, but on comcast the most i have ever got was roughly 90 Mbs on the 2.4g band and thats with wifi. 

Frequent Visitor

Re: Comcast Xfinity speeds work fine on all devices except my Iphone. Why is that?

@jlavaseur Thanks for the reply. Any idea what could be wrong? I'm not too worried about high speeds, but the fact that my iphone is only getting about 1 Mbs makes it almost unusable for anything that needs internet.

Contributor

Re: Comcast Xfinity speeds work fine on all devices except my Iphone. Why is that?

I would reboot everything, which you probably already did, make sure your iphone isnt very far from the router for a test, i use a app called *Speedtest* to test my speeds, i would make sure your iphone has the latest ios firmware, are you by any chance hardwired your computers to the router? or are they using wifi? Sorry i dont have alot of extra ideas, i just mention things i have done in the past that helped me.

Frequent Visitor

Re: Comcast Xfinity speeds work fine on all devices except my Iphone. Why is that?

@jlavaseur Yeah, I rebooted everything and the *Speedtest* app is what I've been using to test the speed on my iphone and it shows that it's getting around 1 Mbs each time I try it. My iphone does have the latest ios update and I'm using the same wifi on my laptops that are showing speeds in the 60 Mbs range. At this point I'm not even sure what to do, especially since my iphone works perfectly fine on all other wifi networks that it's been connected to, just not this one.

Contributor

Re: Comcast Xfinity speeds work fine on all devices except my Iphone. Why is that?

I been doing some reading and come up with 2 things, some say to reset your iPhone network settings, you will have to reenter your info again,  and what is your encryption scheme? I read where wep is not secure and can cause performance problems, they recommend aes if your router supports it, on my gateway/router it warns the n band will only work with no encryption or aes, I am just guessing at things to check,.