Community Forum

Cannot activate new service with personal modem

Karin1973
New Poster

Cannot activate new service with personal modem

I purchased a NetGear router/ modem and recently purchased a wireless plan.  Due to the restrictions, I am attempting my own service set-up between xfinity and my router/modem. When I attempt to activate using the xfinity.com/activate link, it takes me through the screens to link and once I request it, I receive a screen with this message:

Sorry, That Didn't Go As Planned

We are having trouble activating your service. Please give us a call at 1-800-xfinity.

 

Not being able to get through to a customer service agent to discuss this, I am looking to answer the question:

 

My router comes with both a serial number and a MAC address.  The number listed attached to my xfinity account is the Modem router MAC address.  Should this instead be the listed serial number? I ask because xfinity does not seem to recognize or connect to my device.

 

Thanks.

EG
Expert

Re: Cannot activate new service with personal modem

Give this automated device activation line a shot: 1-855-652-3446. Even if the automation fails, you then get connected to an advanced repair representative rather than a tier 1 phone rep. Good luck !!!



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!