Community Forum

Bridge Mode doesn't work

Highlighted
New Poster

Bridge Mode doesn't work

I have a webserver running on a Raspberry Pi that I have connected to my Arris X-Fi Router. Using the painfully slow web interface, I set up a port forward for port 80 to the LAN IP of the Raspberry Pi. When I try to connect to my public address it takes me to the X-fi router log in page! If I set up port 80 as a port forward, it resolves to the private address which is not accessible obviously on the internet. I'm not sure what's going on with X-fi port forwarding of port 80.

 

Thinking that this must be a software issue on the router I decided to set the X-fi to Bridge mode and have my Asus router control the port forwarding but no matter what I try I cannot get internet to work when I have it connected in that way. I connected the ethernet cable from the Asus router's gateway port to port 1 on the Arris. If I connect my ethernet from my computer directly to the Arris, I can get an IP and browse the internet just fine. But when I add my router into the mix it never gets an internet connection. The same ASUS router works in Access Point mode and as a router serving up another LAN when connected to the Arris while Arris is configured as the gateway so I'm pretty sure its not my router. I even cloned the mac address of my PC's nic card in case the Arris was looking for it but no dice. Seems like DNS doesn't work. 

 

So, neither option will allow me to host a simple website on my Raspberry pi.  Since I highly doubt comcast can fix this, is there another router I can buy that will function as either a proper router with working port forwarding or perhaps something simple that allows me to use my Asus router in bridge mode?

Highlighted
Expert

Re: Bridge Mode doesn't work

You have to power cycle the modem after connecting the router to it to be able to gain internet access.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!