Community Forum

Bad connectivity / speed the last few weeks and not sure what to do

Highlighted
New Poster

Bad connectivity / speed the last few weeks and not sure what to do

I live in Portland, Oregon and have seen extremely bad speed and connectivity the last few weeks, and it seems to be getting worse. Specifically:

 

1) Pings to common sites like google.com fail (roughly 10-20% of the time)

2) Sometimes internet connectivity dies for 1-2 minutes and if I am doing things like a video confrerence it stops completely during this time

3) Results on speedtest.net are very low, around 2.6 Mbs

 

I talked to customer service yesterday and during the chat they updated my modem's firmware. Right after that things were much, much better with no connectivity problems or failing pings, and the speed test was over 10x faster.

 

Unfortunately today these problems are back, possibly worse than before, and when I try to chat with Xfinity it just says due to Coronavirus they are transitioning service to work at home and it will take a while, and does not let me chat. 

 

As I work from home this is really a big problem, so I am hoping someone can help me out so I don't have to search for another provider.

 

Because whatever they did fixed things completely temporarily (which only involved the modem, not the router), I'm fairly sure the problems are on their end. Also I am seeing this on multiple devices so I know it is not a problem with a specific device. I guess it could be a bad modem, but I have a hard time believing the modem could be gradually getting slower over a period of time.

 

By the way, I tried the Xfinity speed test but it seemed to not measure anything, since it stayed around 11 Mbs before and after they fixed whatever problem it was yesterday. 

 

Thanks!