Community Forum

ASUS "DHCP not functioning correctly" message

Highlighted
New Poster

ASUS "DHCP not functioning correctly" message

I'm also getting the dreaded "Your ISP's DHCP does not function correctly" message. I have an ASUS RT-AC87R router connected to a NetGear CM500-100NAS cable modem. I can get to the internet via a cable to the cable modem, but the router does not seem to want to connect to the cable modem. What should I try next?

Highlighted
Gold Problem Solver

Re: ASUS "DHCP not functioning correctly" message

Did you power-cycle the modem after connecting the router to it? This is necessary whenever you change the device directly connected to a DOCSIS modem.

New Poster

Re: ASUS "DHCP not functioning correctly" message

Wow, I'd reset and rebooted it to no avail. I'd also placed a MAC address in the router that I deleted while re-powering and it connected successfully.

 

Thank you for the help! I wish such a simple, obvious tip was in the instruction manual, something like "To ensure DHCP compatibility if you get an error message, simply pull the power plug on your cable modem after connecting the router and then restore power."

Highlighted
Gold Problem Solver

Re: ASUS "DHCP not functioning correctly" message


@VarnerD wrote: ... I wish such a simple, obvious tip was in the instruction manual ...

I've always thought that modem manufacturers should print that info across the manual cover and all over the device packaging in BIG BOLD RED LETTERS. Sadly, they don't. Glad you got it!