Community Forum

1 Month+ internet issues still haven't been fixed.

Highlighted
New Poster

1 Month+ internet issues still haven't been fixed.

I've resorted to posting here in the hopes that something actually gets done.

 

Between AT&T and comcast, I've been experiencing intermittent internet issues since March. I had been using AT&T had been working perfectly fine without a single hitch for about 2 years, until March for no notable reason we couldn't use more than a single device without the internet dropping connection every 5-10 seconds. I tried tech support with them until realizing they were far too reluctant to fix my problem, and were adamant that there wasn't an issue at all.

 

Fast forward to June, I switched over to comcast, and immediately had the same exact issue, but the connection was notably stronger when it was connected. I contacted support about a week after being connected, to which they sent a technician out to check the brand new line that was created, found nothing wrong, and raised the issue to the advanced tech team.

 

About a week later, a member from the advanced tech team came out to look at the line a second time, as well as take a look at the telephone pole that our line was running from, which he claimed had no issues. However, he did discover that there was a weak signal coming from the node that our modem is connected to, and said he was going to raise the issue to have the node worked on.

 

About 1 week later, nothing had changed, I reached back out to tech support to find that I had no open tickets, and the node had never been looked at. After 2-3 aggrivating support calls, I finally managed to get someone to check the signal from the node, where they found that there was a weak signal, and they openned another ticket to have the node looked at.

 

I called the following day, only to find that I again had no ticket open, and a tech support member claim that they found no issues with the node. So he created yet another ticket for the tech team to "look into it".

 

2 days later (today), I find out from another support member that I have no open tickets, a month and a half later, with 0 progress towards solving the problem.

 

I'm tired of being brought around the same circles, and am at a complete loss of where else to look, or how better to deal with the issue. I'm currently paying $50 for the use of only one device at any given time.

 

If anyone could share some insight as to who I should call, and how I should go about explaining my issue, I would be greatly appreciative.

 

-Thanks