Community Forum

xfi app

Highlighted
New Poster

xfi app

When I try to log-in to the xfi app, it accepts my user name and password, sends me a verifiation code and then says, invalid ID or password.  I have tried deleting and reinstalling the app.  I confirmed my log-in and password on xfinity.com and xfinity hotspot app.  Is there a separate log-in needed for the xfi app?  

Highlighted
Expert

Re: xfi app

moved post to xfi area of the forum



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Official Employee

Re: xfi app

We are sorry to hear that you are experiencing difficulties. Please try uninstalling the Xfinity xFi App and reinstalling it. Log in to the Xfinity xFi App and try again. You can also log in Xfinity xFi by using the following link: http://xfinity.com/myxFi

 

Also, be sure that you have a Wireless Gateway that is compatible with the xFi App. The following link will let you see a list of the compatible Wireless Gateways: https://www.xfinity.com/support/articles/broadband-gateways-userguides

 

We hope this helps. If it does not help, please let us know. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!