Community Forum

xFi Pod Secondary Network with RJ45

Highlighted
Contributor

xFi Pod Secondary Network with RJ45

I have the issue that when a device is connected to the RJ45 on a pod, it receives IP addresses from a secondary network. The gateway is 10.0.0.X and the secondary network is 192.168.245.X.

I called and the tech supposedly did some tests, but said that the pods were not responding properly and a technician visit was required.

 

The tech came, but said there was not much they could do to troubleshoot pods. He called in and the second line support person said basically the same. He said I could try re-provsioning them from the xFi App.

 

I see where in the past other people had the same or similar issues. Were these ever resolved?

I will try the reprovisioning, but this is a strange way to provide support for a product.

Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

I should mention this was a new implementation of pods. I removed a router in bridge mode and replaced it with the pods.

 

Everything appeared to work ok at first, but then devices started getting IP addresses in an alternate network. The two devices critical to me that must be connected via hardwire are for the solar and Powerwall systems.

 

Initially I thought my home network was hacked and something was bridging into my home network.

Highlighted
Silver Problem Solver

Re: xFi Pod Secondary Network with RJ45


@tnrsmith510 wrote:

I have the issue that when a device is connected to the RJ45 on a pod, it receives IP addresses from a secondary network. The gateway is 10.0.0.X and the secondary network is 192.168.245.X.

I called and the tech supposedly did some tests, but said that the pods were not responding properly and a technician visit was required.

 

The tech came, but said there was not much they could do to troubleshoot pods. He called in and the second line support person said basically the same. He said I could try re-provsioning them from the xFi App.

 

I see where in the past other people had the same or similar issues. Were these ever resolved?

I will try the reprovisioning, but this is a strange way to provide support for a product.


The pods can't be used with ethernet.

https://www.xfinity.com/support/articles/xfi-pods-faqs

 

Note: Be sure to plug your Pods into active electrical outlets. Do not connect your Pods directly to your xFi Gateway using the Ethernet port on the bottom of the Pod. The Pods connect wirelessly to the xFi Gateway. You will not be able to activate your Pods if one is connected directly to the Gateway.


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
Gold Problem Solver

Re: xFi Pod Secondary Network with RJ45


@RobertWy wrote: ...The pods can't be used with ethernet.

https://www.xfinity.com/support/articles/xfi-pods-faqs


The FAQ goes on to say ;

 

What can I do if all my Pods are online, but I'm still having WiFi issues?
... If you're experiencing connectivity issues ... you may benefit from the following:
  • Connecting your device via Ethernet to a Pod
Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

I am not sure your statement applies directly to my situation.

The pod is not connected via hardwire to the gateway. It is connected via wireless.

Two additional devices are conected to the pod using the RJ45 port and a switch.

This is what the second quote refers to I beleive.

Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

I thought reprovisioning may have resolved the problem, as it appears all devices were in the proper network last night.

 

Upon reviewing the xFi app this morning, some devices have reverted to the alternate network. That is assuming the data in xFi is current and accurate. It does not match with what is shown when accessing the gateway interface directly.

Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

I am guessing that the pods set up this secondary network to communicate with each other.

The pods themselves do not identify on the main gateway network and are not granted IP addresses in the main network.

 

It seems to me that they should not be distributing IP addresses to devices on the main network.

Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

So it was suggested that I might need additional pods to cover my house. So I swapped the three-pack for a six-pack. It appeared everything was working OK. When I made the swap at the store, I asked if a reset or restart would cause an issue, the answer was probably not. So this morning with some existing connectivity issues, I reset the modem. After almost two hours on the phone and talking to four people, I am at least back to where I started. After the reset, the pods were not recognized at all. The pods are now back online. No ip addresses in the secondary network at this point. It appears some pods are not providng a good signal though.

 

The attached image shows what happen when a device is granted an IP address on the secondary network.

image001.jpg
Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

I think I know the condition when the secondary DHCP server provides addresses in the alternate network. We had a power outage yesterday. When the power comes back on it seems that the pod that provides the secondary DHCP server reboots quicker than the gateway. With the gateway not available, the secondary DHCP server provides addresses to those devices requesting.

This is all conjecture on my part, but after the power outage I had a large number of devices in the secondary network. I rebooted them after the gateway was on and they all got numbers in the main gateway network.

 

Devices on the pod RJ45 still remain in the secondary network no matter how many time they are rebooted.

 

I was supposed to receive an email or phone call when someone reviewed my case. It has not happened yet.

Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

My situation may not apply to others who are trying to use the RJ45 connection.

 

I have found that by granting fixed IP addresses to the devices connected to the RJ45 that I can maintain connectivity until power goes out(which happened a day ago). This is not ideal as I should be able assign IP addresses through the gateway interface. When the devices are assigned addresses in the secondary network, they are not visible on the gateway tool. It is interesting to note that they do show in the xFi App.

 

In my case I have two devices related to solar equipment connected to a switch which is connected to the RJ 45 xFi pod port. In order to monitor the equpiment, it needs to be on the same network as the home network.

Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

Again this is all guess work on my part. And my situation may not apply to others.

Highlighted
Official Employee

Re: xFi Pod Secondary Network with RJ45

tnrsmith510 -- Thanks for reaching out & I apologize for the frustration. I've pulled up your account and shared with engineering for further investigation. It sounds like there may be two issues happening here - one with the IP addresses and another with Pod connectivity in general.

The switch you have connected to the Pod can be a source of throughput issues for the devices you have connected to it. We will continue to investigate further and I will reach out when I have additional information.

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

Thank you for your reply.

 

I believe the issues may be related just manifesting themselves differently.

Just FYI, I removed all the pods vis the xFi App and then added only 5 back in. It seemed like this helped resolve connectivity issues as I was able to log into the xFi App when connected wirelessly to a pod. However it has been inconsistent and the login times out at times.

 

The throughput on the devices connected to the switch is not critical as it is minimal data about solar production and solar equipment status. For troubleshooting purposes I have a laptop connected to the switch. I just got 35.2 Mbps from the xFi speed test which is more than adequate.

 

Highlighted
Official Employee

Re: xFi Pod Secondary Network with RJ45

tnrsmith510 -- Thanks for providing the update. It sounds like the connectivity issues are in a better state now that one of the Pods is removed. Did you need additional coverage when you only had the 3 Pods?

Regarding the IP Address issue -- engineering has reviewed your account & needs some additional information.

Do you have any DHCP settings configured on the switch itself?

Also could you try removing the Static IPs from the Solar Panel & Powerwall devices and then try removing the switch and connecting one of the devices directly to the Pod via ethernet & report back with your experience? What IP is showing then?


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

Additional pods were suggested as a solution. It is odd that 4 of the five pods are connected to the gateway, even though other pods are closer in range.

If the switch is configured for DHCP, it will receive an IP address in the secondary network. Not all the time, but at some point it will revert to the secomdary network IP.

I will try connecting one of the devices direcrtly to the pod. Confguring the solar equipment is not a simple matter. Identifying the IP address to access it can be problematic. The xFI App and the gateway admin tool do not present the same information, so identifying the device correctly can be involved.

Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

As an additional test, I connected a laptop directly to a different pod via the RJ45. It obtained an IP address in the 10.0.0.X subnet.

 

I configured the solar powerwall interface to use DHCP and connected it directly to the pod bypassing the switch. It also successfully obtained an IP address in the 10.0.0.X subnet. The device is correctly identified as connected in the xFi App. The gateway admin tool however shows it as disconnected.

 

So what is the next step?  I have had the devices get IP addresses in the 10.0.0.X subnet before, but at some point they revert and get addresses in the 192.168.245.X subnet. I will discover this when I try to monitor the solar equipment as it will appear to be offline.

 

Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

Just FYI, I reconfigured all the devices for DHCP and added the switch back. Restarted all devices except for one of the solar devices and all devices have currently leased an IP address in the 10.0.0.X subnet. I will power cycle that device and check the lease.

Highlighted
Official Employee

Re: xFi Pod Secondary Network with RJ45

tnrsmith510 - I've relayed that information to engineering & will let you know when I hear back.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Official Employee

Re: xFi Pod Secondary Network with RJ45

tnrsmith510 -- Engineering took another look and with the solar panel connected directly to the Pod via ethernet, they are no longer seeing an issue.  

They've also requested some additional information -- would you be able to provide the make and model of the switch, solar panel and powerwall.  (Feel free to send me a private message with this information if you prefer.  You can send a Private Message by clicking on my username "ComcastRachelH" & then on the blue "Send a Message" button from my profile.)

Thanks!


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

Realize that currently the switch is back in the configuration and devices are connected to it.

I will send other data privately.

Highlighted
Contributor

Re: xFi Pod Secondary Network with RJ45

I got a phone message requesting the same information I provided privately. I returned the call, but I had to leave a message.

Highlighted
Official Employee

Re: xFi Pod Secondary Network with RJ45

tnrsmith510 - Apologize for the confusion.  I've relayed the information you provided back to engineering.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Official Employee

Re: xFi Pod Secondary Network with RJ45

tnrsmith510 - Thank you for your patience & providing additional detail. In speaking with engineering (and confirmed by your descriptions), it appears that the addressing is working at the moment but becomes an issue when you lose power and the IP Address gets assigned at that point. Unfortunately, xFi Pods aren't designed to support ethernet bridging of multiple devices from a single Pod. Maintaining this configuration will require you to manage the IP of the ethernet connected devices.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!